Facebook Photo Albums Don't Load All Photos

This is a really annoying bug in Windows Phone 8.  The Facebook photo albums in the Photos hub will only load the first 100 photos.  I uploaded over 400 photos to one album and I've gotten hundreds of likes and comments all of which show up in the Notifications tab of the me tile, but when I tap on one and it's related to a photo that is NOT within the first 100, the photo that it is related to will flash for a second and then go back to the 100th photo in the album.  I can't read comments on photos at all. 

Also, if I set the album cover to an image that is not within the first 100 of an album, the album shows as black in the Windows Phone 8 photos hub.  Not cool.  

SkyDrive photo albums do not have this limitation problem. Please fix!

 

Question Info


Last updated October 2, 2018 Views 1,121 Applies to:
I am having the same issues, though I am a Windows Phone 7.5 user (I submitted a similar post here). I was in some ways hoping that perhaps purchasing a WP8 device would resolve this issue, but it sounds like that's not the case.

Like you I am a heavy user of the Facebook photo albums integration; as far as I can tell this is a very recent issue - in the past I have always been able to see complete albums and comments even when there were more than 100 photos in any given album, and find it incredibly frustrating that this is suddenly happening.

A quick search on wpcentral.com forums shows that this is happening to others as well. Hope it gets addressed soon!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Interesting. I wonder if it's a Windows Live cloud connection issue since I remember it working well with more than 100 photos on Windows Phone 7.5, too.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Int(2) used ? 😵

Pffff...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just discovered this issue on my Lumia 920....MS please fix this annoying limitation.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem is still in Windows Phone 8 GDR2 OS version 8.0.10327.77.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem is still in Windows Phone 8 GDR2 OS version 8.0.10327.77.
Still here on GDR3.....MS respond to this issue please. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.