Cannot connect to secure WiFi router

I have seen this problem mentioned and can see similar questions but mostly remain unanswered.

I have a problem specifically with the HTC 7 Mozart and WP7 through Telstra in Australia.  I have two Mozart's and I wish to connect to the internet when at home via wifi through our wireless router. Telstra deliver out of the box default settings to security on their Netgear wireless router for millions of non IT experts Australia wide ("Bigpond"), so basically they are unchanged and would be for most people.  I can connect to this wireless router using the key for an iPad, iPhone, Telstras T-Hub and my Netgear USB key (Rangemax WN111 v2).  But through the WP7 (on the HTC 7 Mozart) I enter thecorrect password key and it states after 15 seconds or so (with the wireless icon flashing) then states:

_____

Connection unsuccessful.

Your phone couldn't reach the WiFi
network <my network>.

[Close]

If I enter the incorrect password it tells me so.

I can't see this being a security issue with the router, given I can connect using default security options with almost any other device.  So offering an answer suggesting changing the router's security settings or allowable MAC's is not a solution.  What I am after however is:

  1. Insight to whether this is an issue with HTC 7 Mozart OR WP7?
  2. Can the issue be addressed as a workaround (short-term) or a fix (in the long-term)?
 

Question Info


Last updated February 10, 2018 Views 13,528 Applies to:
Answer
Answer

Someone indicated the Samsung Focus could not connect via WPA2 - that's not my experience.

My focus is currently connected via WPA2-AES with MAC filtering, at N speed.   At home, I've used both a  Cisco WRT610N, and a WRT350N.

Aside from the inability to customize the WiFi connection that we already know about (can't connect to hidden SSIDs, can't set a static IP), the only other issue I've found is that you can't connect to a network in the 5GHz range.   If you are broadcasting your SSID, but your phone still doesn't see your network, check the range - and change away from 5GHz to fix.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
I have tested Samsung Omnia 7 and LG Optimus 7 with my Netgear WGR614 v8. All possible settings (WEP, WPA, WPA2 AES, WPA2 TKIP) are working fine. So if there are any issues it seems to be some combination of influences rather than a bug in the OS. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.