0x80072F17 Active sync support code error syncing to Exchange server

I received a replacement for Omnia II that came with the version 2 update. I was able to hard sync my home computer successfully but have been unable to connect with my company exchange server, receiving the above captioned error. I run my office from Outlook so HELP!
 
Question Info

Last updated August 13, 2018 Views 14,144 Applies to:

I am not an Exchange user so I am just offering what I found jjgchief.

0x80072f17 is explained as ERROR_INTERNET_SEC_CERT_ERRORS, which means
certificate that was issued to your web site cannot be used for ActiveSync.

Confirm that you have configured your device correctly.  See what happens if you disable the SSL connection between Exchange and PDA.


Jack Cook
http://www.experiencemobility.net

Lead Moderator
Windows Phone Forums
http://social.answers.microsoft.com/Forums/en-US/category/phone
.


Windows Phone ... Just press start and enjoy a true mobile experience

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It looks like your company is using a self signed cert which is just a certificate that was issued by your company which trusts the certificate but other places don't trust the cert.  For you to sync you device you will need to install your companies "root certificate" onto your device.  A quick way to do this using your desktop/laptop is to open internet explorer and go toTools>Internet Options>Content>Certificates>Trusted Root Certificate Authorities and select your companies root certificate then clickExport.  Follow through the menus and save the certificate to your desktop.  Then you can use WMDC to copy the file to your device.  Once the file is on your device you can use the file browser on your device to find the cert then tap on the cert to install it. 
MVP-Mobile Devices
MVP-Windows Phone

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think that this issue occurs when the certificate for IIS has expired. You can check it:
Exchange Server --> Internet Information Services (IIS) --> Your Name Server --> Web Sites --> Default Web Site --> Properties --> Directory Security --> View Certificate

If expired, you just need to renew the IIS certificate:
Exchange Server --> Internet Information Services (IIS) --> Your Name Server --> Web Sites --> Default Web Site --> Properties --> Directory Security --> Server Certificate (renew)

best regards,
Gonçalo Santos

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.