N900 Error Communicating with Exchange Server

Finally, received my n900 last night here in the US.

 

Unfortunately, I just cant get around to setting up my exchange emai. The setup wizard is pretty straightforward (and yes, before you ask, I have experimented with secure and the non-secure options). The setup process fails in the last step with the following popup:

Error Communicating with Exchange Server.

 

This has been going on for the past 12 hours that I have had the phone. I dont understand the problem. The setup process seems similar to the Nokia 5530 and N97 that I have had before and had no problems with. I have tried wifi and 3G separately. Its the same problem.

 

NOKIA please address this fast or I am returning the phone within a few days.

 

Question Info


Last updated February 27, 2018 Views 282,824 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I just rec'd my device as well in the USA and I am getting the same error/issue when trying to connect to my exchange server at work.... any ideas out there???

 

thanks

Tom 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue on a US n900, last step where it says communicating with exchange it says error and to no avail connected my hosted exchange provider and installed certs still to no avail cant get on tried port 80 and 443 with and without secure connection, only settings that got me to the last step was 443 w/ secure connection checked. I wish I could pull logs from the phone gonna try some stuff in terminal

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It could be a bug with the MfE support for Exchange 2003

 

See the bug report:

"First Synchronization between N900 and Exchange 2003 Server fails"

https://bugs.maemo.org/show_bug.cgi?id=5597

 

More discussion at talk.maemo.org:

 

http://talk.maemo.org/showthread.php?t=34198&highlight=mfe

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think N900 supports Exchange 2007 only but not 2003

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Add me to the N900 fails to connect to Exchange list. Not pleased.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Put me on the list as well.  We've got Exchange 2003 and it won't work.  I thought this might be a great platform fo our company to evolve to from blackberries. How do we find out if Nokia's goign to fix or am I (stuck) going to go back to the BB?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

http://talk.maemo.org/showthread.php?t=35136&highlight=exchange

 

One of the technical guys at Nokia behind the MFE component discusses his work and ask for feedback.

 

He mentions that only Exchange 2007 is currently supported, but Exchange 2003 will be supported in an update.

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

supported an update???

 

exchange 2003 update or maemo 5 update?? hope soon

 

when is this update available?

 

we have many customers that does not have mail now on their phones...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

the update for exchange is 2007, but I don't think that's going to help you!! the maemo update to the mail for exchange client has been mentioned but there are no hard dates yet. there is supposed to be an update for the N900 before the end of the year, but that's not certain and it may not include the update you need. sorry

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

even so, exchange 2007 is supported, there are issues

 

i do get occasional sync failure, and it goes into a loop trying to sync and fails and completely drains the battery doing so..

 

this is a serious bug that needs to be fixed 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.