Question

Q: E71 Mail for Exchange System Error, try again later:handling commands from server

Hi,

Please Help!

I installed MfE 2.7 on my E71, but whenever I try to sync my email and calender, I get a system error.

It begins to sync the email but after that it doesn't sync the calender and I get the system error. Also each time it tries to sync emails, it retrieves all the mail each time.

If I sync only the calender, it retrieves all the items and I get a system error. I've pasted the admin log below.

27/10/2008 10:17:42 start Email sync
27/10/2008 10:17:53 sync died (11), collection=Email activity=handling commands from server
27/10/2008 10:22:36 PING Command Requested
27/10/2008 10:22:42 start Email sync
27/10/2008 10:23:01 sync died (47), collection=Email activity=handling commands from server

Does anyone know how to solve this?


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same issue. It first worked but after turning of the phone and turning it on again I got the same error.

Did this solve your problem?

Sorry this didn't help.


Hey,

It started working for me after the IT department rebooted the exchange server. Maybe there was something up with the server. Maybe you can try that.

Did this solve your problem?

Sorry this didn't help.


my E71 running S60 Mail For Exchange works fine for email, but as soon as we start syncing calendar, we get this error "System Error. Please try again later"

 

Maybe it is related to recurring appointments or MFE simply does not have full compatability with Outlook calendar?

 

Has anyone worked this out?

Did this solve your problem?

Sorry this didn't help.


My Nokia E71 firmware v100, MfE 2.9 is very buggy, but worked o.k. with exchange server. just recently, I may have added a contact that the sync doesnt like. however, i dont know which one it is. also I do see in the nokia device empty contact entries, which i cannot view nor delete (i do see then in the car, which connects via bluetooth to the e71 contact names like /W ....). i think i have created such a contact by accident by not locking the phone properly.

 

however, how can i now fix that? a fully resync doesnt do the trick and i have reviewed all contacts in outlook and dont see anyone there anymore that looks odd.

 

here is what "admin_log1.txt" looks like after a sync. i shows that it still tries the full resync for the contacts and never gets thru.

 

2009-05-31 09:27:02 start Email sync
2009-05-31 09:27:04 client->server adds=0 changes=0 deletes=0 fails=0
2009-05-31 09:27:04 server->client adds=0 changes=0 deletes=0 fails=0
2009-05-31 09:27:04 end Email sync
2009-05-31 09:27:04 start Calendar sync
2009-05-31 09:27:06 client->server adds=0 changes=0 deletes=0 fails=0
2009-05-31 09:27:06 server->client adds=0 changes=0 deletes=0 fails=0
2009-05-31 09:27:06 end Calendar sync
2009-05-31 09:27:06 clearing device entries for initial sync
2009-05-31 09:27:06 failed to create Contacts sync command (error=-20)
2009-05-31 09:27:06 Mail For Exchange Error -15000
2009-05-31 09:27:06 Mail For Exchange Error -15000

 

thx,

berndg

Did this solve your problem?

Sorry this didn't help.


i have researched further. The phone log shows the sync falls over on outlook recurring appointments. Some threads suggest the offending appts are those without end dates and adding them will fix it, but this is not correct. Our recurring appointments are created in Maximizer and synced to Outlook. They all have end dates which show in both Maximizer and Outlook.

The log message on phone is: "Failed to store calendar entry in device database". If you google that you come across the link to another thread

/discussions/board/message?board.id=messaging&thread.id=7858

where it seems that MFE simply does not work properly with Outlook calendar recurring appointments and no solution is offered by Nokia. E71's run Symbian S60 and Mail For Exchange is the Nokia offering, which appears to be a derivative of Roadsync. Both appear to have the same shortcoming. Even the latest MFE version, V2.09.158, contains the problem, as we just upgraded on phone to try for a fix.

 

We have a fleet of E71's, having reverted to Nokia from Win Mobile devices. We were even looking forward to N97's, but we are now planning to move back to a Windows Mobile device. At least we can see the calendar on these!

 

For now, we have to remove calendar syncing on phone and delete all calendar entries, so the phone again syncs for email and contacts.

 

Nokia, how about a FIX before your new generation of "Smart Phones" are consigned to the wastebin? Please don't just tell us to change a setting on the server, unless you know it works.

 

This is your last chance with us. Time is too precious  to waste on dodgey software.

Did this solve your problem?

Sorry this didn't help.


I did completely wipe the phone by re-flashing the original firmware, reinstalled everything and then MfE synced all fine. Thus it was not a data problem, it was a corrupt MfE/contacts database which could not even be fixed by deinstalling/reinstalling MfE but required a complete phone wipe.

 

-Bernd

Did this solve your problem?

Sorry this didn't help.


berndg,

 

It will sync fine initially.  However, in the next couple of days you'll more than likely see it stop working again.

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


since i started this thread, i gave up and bought an iphone instead. best phone i have ever used, so i'm now "converted" to apple. easiest to set up and use. trouble free. calendar and  email all syncing faultlessly and much more info, plus easier to see it all. you should try it.

i had been waiting for N97 but not any more. before E71  i had been on win mobile, but that is still nowhere near as good as iphone.

Cheers and signing off

tb56

Did this solve your problem?

Sorry this didn't help.


For those who found this thread, as I did, looking for a solution to the m4e syncing failing problem, here's how i resolved it:

 

Only sync email (not calendar, contacts or tasks) and see if itworks ok now. Add them one at a time until the problem appears, this gives you the smoking gun. Through this process of elimination I found that it was my calendar sync that was causing problems. In the setting for intial sync I selected "delete items on phone"rather than "keep items on phone" and that solved the problem.

 

I guess there was an existing appointment causing a conflict or something. Anyway, it worked for me.

 

Good luck.

 

Keep the faith and resist the iPhone! 

 

Did this solve your problem?

Sorry this didn't help.


Found the problem..

 

we running exchange 2003 and 2007.. we found that any calendar, contact or task with blank subject will cause this problem.

 

check also for any corrupted messages.

 

Regards

 

HSV

 

Did this solve your problem?

Sorry this didn't help.


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
Question Info

Views: 300,432 Last updated: July 10, 2018 Applies to: