Microsoft Lumia 640 XL Dual Sim, Problems With Dual Sim. It Seems Dual Sims Blocking My Cellular Data

20150719
.
The Problems I Got since May 31, 2015 When Both Sims Are Activated: (it kinda block my cellular data)
* Email
Pictures won't show up at all although U can see it is downloading or it takes a very long time
.
* Facebook
Pictures on Facebook posting take a (very) long time to show up or IT DOES NOT SHOW UP AT ALL
On the top it says: "We can't refresh the news feed right now. Try again in a few minutes"
.
I can not open the Friend Request section on fb
Sometimes It need me to switch back to other apps back and forward quite a few times before I can open it
.
OneDrive
* Can Not see all the pictures inside a folder on OneDrive
* Can Not upload a single photo to a folder on OneDrive
.
Browsing
* The first page is open normally, but when I tried to click on a menu it will not open (blank)
.
YouTube
* It took ONE MINUTE just to load the page
It took only (half) ONE SECOND to load the page with a single SIM
.
* And some other issues that I forgot to mention
.
.
When I use one SIM card only, I do not get the problems mentioned above.
.
This ones happened a few times only, when I use Wi-Fi with both Sims activated, I got a little bit problem similar to the problems mentioned above, but not always or you can say, very seldom.
.
So yeah this is about not getting the internet data fluently when both Sims are on its place.
However, this is a dual SIM phone, and it has to be running well when we place both sim cards on its slot, and the truth is just the opposite.
.
Many thanks for your kind attention and hoping for any solution or ideas.
 

Question Info


Last updated July 8, 2019 Views 4,220 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Make sure you have correct date and time settings and SIM configurations . Contact customer care of your particular SIM.
Just that !

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

20150727
Thank you Aditya X17
.
Sorry for late reply
.
I have checked and re-checked my date & time settings and Sim Card configuration from mobile providers.
Both are on the right setting and configuration (I follow instructions from mobile providers)
The result is still the same.
When dual SIM card is active it will bring problem to internet access.
.
Just now I re-re-checked the problem and it stays there.
When Dual Sims activated:
(First SIM card 3G and second SIM card no internet access)
I opened two websites.
The first one did not allowed me to login AT ALL ( I tried three times and cannot login) and the speed was turned to slow.
The second website allowed me to login but the speed was slow.
.
When I turn off dual Sims and use only the first SIM (I use only 3G depends on the signal)
Both websites opened fast and I was able to login to both of them without any problem.
.
There is a problem when dual SIM is activated (dual stand by), however I cannot tell if this is a software or hardware problem.
.
If I bring my Microsoft Lumia 640 XL to Nokia Service Center in my town, I do not know whether they can fix this kind of problem easily.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, have you found anything? I have the same issue with my 640 XL (non-LTE). Thanks for the "pointer" that it might be a dual-SIM issue, I observed intermittent data drops but couldn't pinpoint it.

What I noticed is that it only seems to affect certain operators as I had no issues in full dual-sim configs for some other operators in my region.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi T_4 

Thanks for your info 

My Microsoft Lumia XL 640 Dual Sim is also NON LTE.

.

I will check the internet quality with different operators and I will get back to you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you by any chance check what band(s) the operator you have problem with operates on?

See here:

https://en.wikipedia.org/wiki/List_of_UMTS_networks

I have found it's only the operator working on 850MHz band that I have issues with. All other operator SIMs in my region worked fine, with no drops. And today, I have confirmed that switching off 2nd SIM really solves the issue so thanks for that.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi T_F4 

.

Sorry for my late reply 

I have checked that my Lumia 640 XL get problems on a frequency of 2100 MHZ (one of my sim card have two frequencies, 2100/900). I checked on the link you gave me. 

.

The issues keep on going

when the second sim card is active: 

* I can not send a message on Facebook Messenger. 

As soon as I deactivated the second sim, I was successfully sent my message on Facebook Messenger. 

.

* Also, my Lumia could not show some piages (where you can touch the pictures and open a new page on websites). 

.

So, the list can keep going on with new problems.  

.

Maybe the only solution is to wait for Windows 10 Mobile go on public on October?. 

.

I give up

.

I think there is no solution right now except to DEACTIVATE THE SECOND SIM CARD while using internet . For that, I need to go back and forward on settings in order to activate and deactivate the second sim card. 

.

Did I get a defect Lumia? 

Will this problem be solved by software update or wait for Windows 10 Mobile?. 

Or this is because of a poor quality asurance at the factory?. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for confirming I think it is a hardware or firmware (not operating system) issue as it happens only when the 1st SIM operates on 2100 MHz, which is relatively rare. I tried it with 2-SIM configuration with operators that are not on 2100 MHz and the issue did not appear (same second SIM). Wondering if anyone from MS monitors this thread or what's the best way to raise this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

FYI,

My first sim is on frequency 2100 

My second sim is on frequency 900/2100 

.

When I deactivate my second sim card, that means my first sim card is still on frequency 2100 and by doing that some or most of the problems are gone. 

.

My situation maybe different than yours, but it is definitely a problem with (a few or some) Microsoft Lumia 640 XL Dual Sim. 

.

Maybe some of Microsoft Lumia 640 XL owners do not care about the problems or just do not know there is a problem.

.

I am a BIG Fan of Lumia series and I hope this small but annoying problems does not carried away to Windows 10 Mobile 950 XL Dual Sim or what ever dual sim series because this time Microsoft/Lumia needs to proof to the people of the world. 

Please do not let us down again and again Microsoft.

I always promoting my Microsoft Lumia 640 XL and my other Lumias to my friends and more. And some of them bought Lumias or going to buy new released Lumia. 


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes that totally aligns with my issue.

- If the first SIM operates on 2100 MHz network and second SIM is active (even with data disabled) the data on SIM1 drops out
- If the first SIM operates on other than a 2100 MHz network and second SIM is active there is no issue
- If the first SIM operates on 2100 MHz (or other) and second SIM is inactive there is no issue

I have tested this with a combination of different operators for SIM1 and SIM2.

I suspect this is a relative rare problem because 2100 MHz networks are relatively few and not all countries import the dual sim version of 640 XL.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you T_F4 for your time testing it

.

I hope Microsoft is doing something to fix this problem so it will not occur in the future (uhumm Oct 06). 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.