Lumia 950XL April 2018 Update - Stuck on Logo at Restart

My Lumia 950XL took the April 2018 update last night. I selected to Restart Now and the update applied. After it restarted, the phone was stuck on the blue Windows logo for an extended period of time. This isn't the first time I've experienced this issue with an update -- the last time it happened, I simply forced a restart by holding the power button and the migrating data steps proceeded. Not this time. Repeated forced restarts, including removing and replacing the battery had no effect on the outcome. 

I decided to pull the 200 Gb MicroSD card holding my music, photos, and files and try yet again. This worked and the updated completed. I then powered the phone off and replaced the MicroSD and restarted with no ill effect.

-steve

And...

It happened again with the May update received overnight.

When I awoke and picked up the phone, the Windows logo displayed. I knew what it had to be, so I powered off, removed the MicroSD card, powered on and the update completed. Powered off, replaced the card, and powered back on.

-steve

^_^
Windows Insider MVP (Security)

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same here. I hard booted my 950 (not XL) (but the Same) .So, I did that twice. Waited almost an hour and restarted normal. and it installed the rest of the way just fine. all is well. 

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same here with my 950. Has been happening for every single update in recent history. So I need to manage when it updates so that I don't miss alarms in the morning. Usually a routine of waiting a period of time after the reboot and it sticking at the logo screen, usually something like an hour. Then press and hold the power button until it reboots. Last time tried this too early and had to repeat the procedure a few times.

I haven't tried the removing of the SD card as I hadn't thought that this was the cause of the issue.

You know, its almost as though nobody at Microsoft actually runs with a Microsoft phone OS anymore and so no real testing of the updates actually goes on. Its bad enough being abandoned for no good reason. Made worse having to put up with the bugs in Windows 10 Mobile that you know wont ever be fixed.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yep. And the 950 doesn't like the SD card. I have had it scan 2 times lately. On a whole, though, better than an android or iPhone!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

With last Windows update (14 November 2018), on my 950 XL, I had to reboot more than 30 times for the update to finish.

I also tested

  • removing the battery (which worked for my 850XL several months ago)
  • without the SD card (which solved my problem last time)
  • without the SIM ... 
  • without the SD and the SIM ... 

I also tried to wait 1 hour on the blue logo.

And also let it Off for more than 10 minutes ...

I am really wondering what's behind this problem ... and is Windows 10 Mobile doing something during this blue logo ?

Bisounours,
Arfy

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My issue became worse with the June update -- https://answers.microsoft.com/en-us/mobiledevices/forum/all/and-another-bad-update-950xl/9f4db6bc-896a-47c5-8062-bc2c66387c86 

As noted in that thread, I ended up using the Device Recovery Tool to restore the phone. Knock on wood, the subsequent updates have gone fine. 

-steve

^_^
Windows Insider MVP (Security)

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks.  But with Device Recovery Tool it removes all apps and history.

As if they should be backup-ed ( I checked https://support.microsoft.com/en-us/help/17232 ) I fear a little loosing things and having to install all again.

Remark about https://support.microsoft.com/en-us/help/17232/windows-10-mobile-back-up

I don't have this menu in my Windows 10 Mobile:

To back up your text messages, sync them among your Windows 10 mobile devices. Go to Settings  > System  > Messaging, and turn on Sync messages between devices.

Bisounours,
Arfy

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It was a last resort for me and a major pain! No data lost as I use onedrive, but still painful with lots of app installs.
^_^
Windows Insider MVP (Security)

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I did it 2 days ago.

The 3 Windows Updates to 1709 passed without blocking on the blue logo. *cool*

I just had 3 problems

  • the restore: it installed ALL the apps I own (on the SD), not the ones which was previously installed
  • Message during the data restore, something like "not all applications' data was restored", but I didn't notice a problem since there
  • I have Whatsapp installed but in application's list I see it twice, one grayed, once working.  I tried to uninstall it and install it again, but the second icon is still there
Bisounours,
Arfy

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated October 3, 2020 Views 558 Applies to: