Can't add Gmail accounts to Lumia 950

I bought another Lumia 950 today and cannot add Gmail accounts on it. Whenever I try to add one, it takes me to a Google page saying my web browser is out of date. It tells me to download Firefox or Chrome or Internet Explorer or Safari. Mind you, this is a desktop page it seems so obviously I cannot download any browser from there (or the Store for that matter). Please help, I'm a student and need those email accounts on the phone.
 

Question Info


Last updated February 14, 2019 Views 927 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi, camelia69420.

Thank you for posting your query on Microsoft Community.

To add your Google account on your Lumia 950, please follow the steps below:
01. Go to "Settings".
02. Tap on "Accounts".
03. Tap on "Your email and accounts".
04. Tap "Add an account".
05. Tap "Other accounts POP, IMAP".
06. Enter your Email address and Password.
07. Tap the Sign in button.
08. Once you're signed in Open the Edge browser.
09. Visit gmail.com and log in to your Google account.
10. Open the message with the subject "Blocked sign-in attempt for security reasons"
11. Tap on the Allow Access button.
12. You will be forwarded to the Google security setting page. "Under the Access for less secure apps", select "Turn on".

Wait for the settings on the phone to update, and your Google account will work on your phone.

Please let us know if it helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey,

Thanks for the quick response.

And yes; For the first account with one pass authentication access path it works well.

 

But: For Gmail account with two pass authentication I get the message - translated form Dutch to English:

 

Less secure apps

Some apps and devices use less

secure login technology, which makes your account vulnerable.

You can disable access to these apps as we recommend, or enable access despite the risks anyway.

More information:

This setting is not available for

accounts that authentication in two

steps is enabled. such accounts

need an app password

access to less secure apps.

More

information

Google Terms & Privacy Help

google.com/settings

----------------

 

what to do

 

Much regards,

Joop46

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This worked to log in to the email, but now it says that email settings are out of date. I have no idea what to do, I've messed around with the settings with no luck.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

----------------------------------------------------------------
"Remember that a lone amateur built the Ark. A large group of professionals built the Titanic."

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Following the steps from Rowena Cam, I was able to get my mails sync'ed.

I created an APP password via https://security.google.com/settings/security/apppasswords - however, this doesn't solve the fact that I don't have access to my Contacts, nor my Google Calendar(s).

So this can be considered a temporary work around to fix mail access, but not a solution that actually resolves the issue. Thanks Rowena, but we need one better :- )

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So this can be considered a temporary work around to fix mail access, but not a solution that actually resolves the issue. Thanks Rowena, but we need one better :- )

The solution is probably google undoing whatever they did to break it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I read in other threads around the internet, that people historically resolved this by switching their browser to desktop version, but this renders the same issue on whatever authentication page at google you are being directed to.

Are you or anyone else aware of any alternatives to Microsoft Internet Explorer EDGE browser (UC doesn't seem to work), that allows you to display this specific page at google?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I have found a solution, at least for me now it works normally. Log-in in your G-mail account and go under Setting/POP and IMAP section, under IMAP access simply activate IMAP flag. After that you can add your Gmail account from your W10m device whit the integrated function (select Account-add account-Google), no more browser erro for me.

Now Microsoft, if you want to hire me I'm available, just saying :D...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the detailed description.
Unfortunately, I can't find the "IMAP flag"
I read it in the Dutch and then I find in the horizontal line
(https://mail.google.com/mail/u/0/#settings/fwdandpop)
"Doorsturen en POP/IMAP" translated: "Forwarding and POP / IMAP"
I can't find the "IMAP flag"
If possible please more details.

Regards,
Joop

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You should see a box, just activate it selcting it and yo are good to go.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.