Version 83.0.478.37 on Mac Crashes 100% when trying to launch Incognito Mode

Question
532 Views | Last updated February 17, 2021

Hello MS Team,

Version 83.0.478.37 has been just disastrous on my Mac since I updated it yesterday. Everytime I launch "Incognito Mode", the whole program crashes. Let me know if you need any logs to help correct the issue.

Is there a way I can roll back to the last stable version?

|

Am I the only one who is facing this issue?

I tried uninstalling and re-installing Edge. Still the same issue persists.

Mac OS version 10.15.4

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Please use the feedback mechanism (Settings and more > Help and feedback > Send feedback) to report this fault. This will alert the Edge team to the problem and can automatically submit diagnostic data to help them find out what's going wrong.

Noel Burgess MVP (Ret'd)

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same here. Starting fresh eliminated the problem for a little while, but it came back after a couple hours. I'm doing regular upgrades, not on a test/unstable branch.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same exact issue. Running 10.15.5 with EDGE Version 83.0.478.45

Uninstalling.... Going back to Safari.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same on Mojave.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I did that a week ago already. There was another update for the browser since and it is still happening.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Just got updated to Version 83.0.478.50 (Official build) (64-bit) and it's still crashing.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hey, good job, version 83.0.478.54 now fixes this problem.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Im only using it for a work-related function that requires a Chromium-based extension; otherwise, I have no use for it. I figured it would be at-best a more privacy-concious and less-invasive alternative to Chrome.

The crashing issue is not nearly as concerning as how this got past QA before release, and seemingly has remained there for weeks before a fix.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Related Forum