Switch to Chrome Notification

6045 Views | Last updated September 9, 2021
Hi Microsoft,
Everytime i open Google Website www.google.com in "Microsoft Edge" Web Browser i get a Notification i.e "Switch to Chrome for Windows".  Why is Google promoting it's Web Browser  "Google Chrome".  Is there any way to stop this Notification. 

I think Microsoft should also start promotion's & Ads of it's Web Browser "Microsoft Edge". 




Thank you for writing to Microsoft Community Forums.


We understand your concern as you are getting the Switch to Chrome for Windows notification, every time you open a google website in Microsoft Edge.


Normally, when you click on “No thanks” the prompt should not come back in the next session. We would recommend you to clear cookies and browsing history to check.


However, you can try these steps and check if you are getting this issue.

  1. Open Microsoft Edge and click on the three dots from top right corner.

  2. Select Settings from the dropdown.

  3. Click on Site permission from the left pane.

  4. Select the arrow beside Pop-ups and redirects.

  5. Under Block add the google website.

  6. Go back to Site permission and select the arrow beside Ads.

  7. Toggle the switch to On.

  8. Close the browser and check


You may also try this steps and check

  1. Press the Windows key + i or enter Settings in the search box in the Windows taskbar to open the Windows Settings app.

  2. Start typing "notifications" (without the quotation marks), and then select Notifications & actions settings.

  3. Scroll down to Get tips, tricks, and suggestions as you use Windows and slide the switch to the "Off" position.


Let us know how it goes.


Aditya Roy

Microsoft Community – Moderator

6 people found this reply helpful

Was this reply helpful?


Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.