Microsoft edge running very slow

Question
6569 Views | Last updated September 19, 2021

Hi 

My laptop just updated to Edge and its running very slow. It takes over 10 minutes just to load one page. 

It has also stopped internet explorer working and getting error message ‘Cannot reach this page’. 

i even tried to download Chrome but its not allowing that either. 

Any ideas how i can fix this? This is a new laptop and now cant use it! 

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi, Lainsey. Thanks for reaching out! I'm an Independent Advisor and a Microsoft user like you, and I am here to work with you on this issue.

I understand how difficult it is, when the device or app won't work in the way it should. Sorry about that.

Lainsey, try to reset Edge to its default settings. If if this fixes your issue and let me know, ok?

1. Open Edge
2. Navigate to edge://settings/reset
3. Click on Reset Settings
4. Click on Restore settings to their default values
5. Click on Reset

I hope this helps!

Kind regards,
Leonardo Mesquita

6 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi, 

I’ve tried to reset this and its still not fixed it. 

Any other suggestions? 

8 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Any other suggestions? 

Are you using Bitlocker?

Noel Burgess MVP (Ret'd)

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've had horrible Edge (Chromium) performance problems for ages - all new pages took an age to load.  After days of investigations I've tracked this to the Edge Secure DNS settings and the fix is trivial.  Go into Setting -> Privacy, Search, and Services and turn off Secure DNS.  
I had a really odd custom secure DNS setup configured and I don't know where it came from, but removing it cleared up the issue immediately.
Hopefully this will help others with similar problems.  

23 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've tried both those fixes and it's still super slow loading. The rewards tab crashes out 50% of the time and very often Edge loses the recent tabls on a new page. I'm starting to think it's just a 'bad' browser. 

5 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This didn't do anything for me, but the browser has suddenly started taking ages to load a page. If I look at the bottom for activity, it shows that it's taking incredibly long times to connect to browser.events.msn.com, which is the "home page" for a new tab which displays all sorts of tabloid news and which celeb is fighting with whom. You know.... incredibly useful and relevant news.

Anyhow, it seems that that's where my slowdown has originated, as I can open a new tab and paste a URL, and it takes upwards of 10-20 seconds to stop loading browser.events.msn.com and then load the actual page that I want.

6 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I gave it my best shot but Edge is just painfully slow. Loading the identical extensions as I use in Slim Jet (A chromium browser) I get consistent browser scores with Edge at 1150+ while Slim Jet never tests over 850. That's about 25% slower using Edge. I've tried all the 'speed up Edge' suggestions I could find but my testing was on the same desktop using the same version of the same extensions and Edge just cant compete.

After 4 hours of wasted effort trying to get Edge to be at least as fast as my current browser, my advice is to switch to Slim Jet....

4 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm having identical problems on a BRAND new PC.  I don't understand the issue here.  It's definitely Microsoft Edge related, as I have no issues with any other software or hardware.

3 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I just started having this same issue with Edge.

2 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have found closing Edge for a minute or so then restarting it helps. If you watch via Task Manager when you close Edge it takes a while for all the processes to close. Had the same problem with Chrome. Switched to Edge a few months ago to hopefully get better results but no.

1 person found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.