How to prevent video autoplay in Chromium Edge

Hi

I've upgraded to chromium edge but now videos are autoplaying again. I had this disabled on classic Edge but can't work out how to do this on the new version.

I've set "Media autoplay" to "Limit" in the "Site Permissions" section of settings but this doesn't seem to have had any effect at all (yes, I've restarted Edge / Windows).

I had also had this problem with dev / beta builds of Edge but hadn't got around to chasing it up until it became my primary browser.

In particular it's annoying on the MSN new pages linked to from the new tab page in Edge when they all have autoplaying video.

Thanks

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi MogZero,

          

For More Tips And Tricks Please See 

https://microsoftedgetips.microsoft.com/

I Hope I've Helped You

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't get Block as an Option. I only get Allow or Limit, and Limit doesn't do anything.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You may have to enable the flag that allows for the block option. Type edge://flags into the address bar, then type media into the search box to see all flags affecting media. Check that Show block option in autoplay settings  is set to Enabled.

You'll find lots of other options to experiment with there.

Noel Burgess | Certified Pedant | Claims to know a bit about Windows Live Mail

64 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi David,

          I have the same settings listed as you do. I posted this Information from the Edge Tips section Here @ https://microsoftedgetips.microsoft.com  However my "Limit" setting does work properly.  Please see the Information iFiredog Posted in this thread. You will find a lot of very useful "Flags" Settings there.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You may have to enable the flag that allows for the block option. Type edge://flags into the address bar, then type media into the search box to see all flags affecting media. Check that Show block option in autoplay settings  is set to Enabled.

You'll find lots of other options to experiment with there.

This solved the issue for me. My "block" option re-appeared. It's so annoying to go visit a news site like ABC News and have video automatically start.

What I wonder is, why take the block option out in the first place?

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found this option for turning block back on and I set the edge option to block. It's better than it was since it at least mutes the audio  but the videos still play. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This needs to be fixed. The old edge just outright blocks it until you click the play button. NO THIS IS SERIOUS PROBLEM.

if it is hidden under a flag this means it is not fixed. Does the block function block the autoplay video on youtube? 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I set the flag per the suggestions above. The block option appeared. I set the site permissions to block autoplay, and it doesn't work. I still have videos starting up when I open certain websites. This sucks.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have set Edge up with "Block" but it doesn't work very well.  Some sites it works others it doesn't (e.g https://www.news.com.au/ ).  Very annoying that many videos still autoplay.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have enabled the block option using the flags (hidden options), and selected block for the autoplay settings, then restarted Edge, but it doesn't work. Videos autoplay in every website I visit. 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 18, 2020 Views 10,802 Applies to:

Related Forums