Fast scrolling

Question
5347 Views | Last updated May 16, 2021
Ever since the new chromium the scroll feature is way too fast,uncontrollable.I have a Lenovo Y700 with the ELAN pointing device,and i have installed the latest driver from lenovo.This wasn't like this on EDGE and all other browsers work fine.Scrolling in windows is good just this browser.I have tried all settings in the touchpad control and they have no effect on scrolling.any fix for this?
|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same problem and have tried a lot in the past few months.

The problem is only in Edge.

I don't have the problem in Google Chrome either!
The scroll speed is faster, the slower I move my finger.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have an Ideapad 330 with ELAN touchpad drivers. Faced exactly the same problems. Fast scrolling only in edge chromium. Browser is up to date, so are the touchpad drivers. Vertical mouse scrolling is 3 lines at a time. Other browsers like chrome and opera aren't affected.

Finally, found an 4 year old reddit post with a fix. This solved my issue.

https://www.reddit.com/r/techsupport/comments/3lhmhq/win10_elan_touchpad_scrolling_issues/

Hope it helps :)

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have an Ideapad 330 with ELAN touchpad drivers. Faced exactly the same problems. Fast scrolling only in edge chromium. Browser is up to date, so are the touchpad drivers. Vertical mouse scrolling is 3 lines at a time. Other browsers like chrome and opera aren't affected.

Finally, found an 4 year old reddit post with a fix. This solved my issue.

https://www.reddit.com/r/techsupport/comments/3lhmhq/win10_elan_touchpad_scrolling_issues/

Hope it helps :)

Here's a verification of https://answers.microsoft.com/en-us/profile/d12ed8db-b7db-46ed-967b-84f29304571c fix:

Create new system image called "Before Elan Modification".

Open Regedit.

Search for Elan.

Change ScrollControl_Mode (or similar depending on version) from 0 to 1.

Reboot.

Note: Did not fix the everlasting MS Photos vertical scrolling problem.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm also facing the same issue in Lenovo Z51 model. This happens only in new Edge chromium browser!!!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm also facing the same issue in Lenovo Z51 model. This happens only in new Edge chromium browser!!!

HI,

here is the fix I used:

  1. Open regedit.exe using run

2. Go to HKEY_CURRENT_USER -> SOFTWARE -> Elantech -> Smartpad

3. Double Click on  ScrollControl_Mode and change value from 0 to 1

It worked for me.


5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm also facing the same issue in Lenovo Z51 model. This happens only in new Edge chromium browser!!!

HI,

here is the fix I used:

  1. Open regedit.exe using run

2. Go to HKEY_CURRENT_USER -> SOFTWARE -> Elantech -> Smartpad

3. Double Click on  ScrollControl_Mode and change value from 0 to 1

It worked for me.


Woah! cool man. This fixed the issue. Thank you so much :)

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem, only happen in new edge and 360 browser, but chrome is fine. can't find earlier touchpad driver for my yoga-700-14isk, only one version found on Lenovo website
Never born a geek, just always f**ked up by gadgets.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem, only happen in new edge and 360 browser, but chrome is fine. can't find earlier touchpad driver for my yoga-700-14isk, only one version found on Lenovo website
Follow the above fix. It worked for me :)

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

+, the same issue, lenovo y700 laptop, tried all the flags, tried changing settings in windows, but that was totally ineffective. I don't  have scrolling issues with chrome, old edge, but haviling them with pre-release versions and release one.

I have also sent feedback during my usage of Canary version, but I still haven't received any feedback on this. And the issue is still present.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

+, the same issue, lenovo y700 laptop, tried all the flags, tried changing settings in windows, but that was totally ineffective. I don't  have scrolling issues with chrome, old edge, but haviling them with pre-release versions and release one.

I have also sent feedback during my usage of Canary version, but I still haven't received any feedback on this. And the issue is still present.

I used the windows mouse drivers on my Y700 and its working fine

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.