Black screen on Edge chromium

Is there any solution to black screen issue when trying to open Edge chromium browser? I am using latest Win 10 pro.

Hi IA. I'm Greg, an installation specialist, 10 year Windows MVP, and Volunteer Moderator here to help you.

I'll give you everything that works to fix Edge so at least something will work:

Back up your Favorites first in Edge Hub (three dots top right of browser) > Favorites > Manage Favorites > Export to file. If you can't reach Edge you can install the tiny app Manage Edge Favorites here: http://www.emmet-gray.com/Articles/EdgeManage.html to do this, which also gives Edge all of the Favorites Management enjoyed in Internet Explorer.

You can reset new Edge in Edge Settings > Reset Settings, or for old Edge in Settings > Apps > Apps and Features, scroll down to Microsoft Edge, highlight it, choose Advanced Options, then Repair, or if that fails, Reset.

If that doesn't help then try re-registering the app following Option Two here: http://www.tenforums.com/tutorials/3175-apps-re...

New Edge is available for download here: https://www.microsoft.com/en-us/edge and will replace the old one. To run both see here: https://www.tenforums.com/tutorials/144061-enab...

I would have several browsers on your task bar so there's always one that's best for the task. I use Firefox, Edge and Chrome in that order of preference. It's easy to share bookmarks between all of them in their settings under Import Favorites from another Browser, and Firefox and Chrome let you sign in to save and/or sync your Favorites on any other device you sign into. Set the preferred browser as Default in Settings > Apps > Default Apps.

If nothing else helps then run a Repair Install by installing the Media Creation Tool and choosing from it to Upgrade Now. This will also bring it up to the latest version 1909 which you need anyway by the most stable method. http://windows.microsoft.com/en-us/windows-10/m...

I hope this helps. Feel free to ask back any questions and let us know how it goes. I will keep working with you until it's resolved.

________________________________________________________
Standard Disclaimer: There are links to non-Microsoft websites. The pages appear to be providing accurate, safe information. Watch out for ads on the sites that may advertise products frequently classified as a PUP (Potentially Unwanted Products). Thoroughly research any product advertised on the sites before you decide to download and install it.
_________________

Windows MVP 2010-21

Over 100,000 helped in forums in 10 years
I do not quit for those who are polite and cooperative.
I will walk you through any steps and will not let you fail.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Right, Now look at my edge window and tell me where to find the settings..

the part that's not black is my windows background. the browser is just one big black rectangle.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Disable your display driver in device manager and then open edge. In the settings, under system disable hardware acceleration.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It is unfortunate that Edge Chromium still shows such an issue. This issue was solved by a bug fix from Microsoft. But if it is still an issue, follow the below steps.

Invoke the browser’s task manager by pressing Shift+ESC. Then it’s possible to kill the GPU process to enable the browser to render again.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It is unfortunate that Edge Chromium still shows such an issue. This issue was solved by a bug fix from Microsoft. But if it is still an issue, follow the below steps.

Invoke the browser’s task manager by pressing Shift+ESC. Then it’s possible to kill the GPU process to enable the browser to render again.

Disabling hardware acceleration in Microsoft Edge Settings worked.  The problem is how to get to this setting when the screen is black.  I got lucky by poking around on the black screen and managed to find Setting on the black screen.  Move the mouse cursor around the top right corner (a pop-up tips will appears when moving the mouse pointer around there).  Then click Settings around the left middle area, finally clicking disable hardware acceleration on the right top area. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I actually uninstalled the chromium version and later upgraded to Windows 10 2004 where edge chromium is installed automaticly. Now it works.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Found that turning off hardware acceleration was a solution for the same issue affecting Chrome users as well. Turning off hardware acceleration fixed the issue with the new Edge browser for me.

Note: Released Version 83.0.478.45 (Official build) (64-bit)

The Dev Edge version did not have this issue and hardware acceleration is on. 

Dev Edge is Version 85.0.531.1 (Official build) dev (64-bit) as of this writing.

To get to a non-black screen in Chrome or Edge and disable hardware acceleration: 

  1. Right click "Start" button
  2. Click "RUN" on the menu
  3. In the "RUN" box, paste the following based on your browser:
    • Chrome: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-gpu
    • Edge: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe"--disable-gpu
  4. Go to "Settings" in Chrome or Edge
  5. Go to "Advanced" in Chrome or "System" in Edge
  6. Disable "Use hardware acceleration when available"
  7. Restart the browser

For a temporary fix until the issue is repaired: 

  1. Right click on the Google Chrome or Microsoft Edge shortcut on the desktop
  2. Go to "Properties"
  3. Go to the "Shortcut" tab In "Target" you will see the existing path and name.
    • They look like this:
    • Chrome: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
    • Edge: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe"
  4. Add or write "-disable-gpu" without the quotation marks.
    • It should look like this:
    • Chrome: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"-disable-gpu
    • Edge: "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" -disable-gpu
  5. Click "Apply" and then "OK"
  6. Start Chrome or Edge using the desktop icon.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Here's the solution : https://youtu.be/rEpvoSHhBaQ

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

For me the issue was caused by Radeon Image Sharpening enabled at the same time as Edge hardware acceleration.  Disabling either resolves the issue. 

Radeon Image Sharpening is a graphics driver feature for AMD GPU's, including CPU integrated GPU's, which is enabled by default when you select the Gaming Profile in the Radeon Software application or if selected when installing an updated version of the graphics driver.  You can disable it just by launching the AMD Radeon Software application, clicking the Graphics tab, then set Radeon Image Sharpening to disabled.  

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I can only speak from the standpoint of being an Nvidia Geforce user and recently ran into this problem, for the second time in my life, while upgrading my graphics card and NONE of the other solutions worked.

Pull up the Nvidia Control Panel

- Manage 3D Settings

- Scroll down until you see "OpenGL rendering GPU"
-- If it says, "Auto select" (which is preferred by Nvidia)
--- Select a specific GPU and click APPLY (If you have two GPUs- pick one)

In Microsoft Edge, go to edge://settings/system or in Chrome, to chrome://settings/system

- Make sure "Use hardware acceleration when available" is enabled. Restart the browser if necessary

Hopefully, this will work for you!

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 17, 2021 Views 2,005 Applies to:

Related Forums