Word 2011 for Mac, document becomes uneditable, menus become blank, program crashes

Hello,

I am running Word 2011 for Mac updated to 14.2.4 on a Macbook Pro I7 with OS X 10.7.5.
I am having real trouble with Word since several months.
When I work on a document with many markups, all of a sudden:
- document starts displaying squares and gibberish instead of the text
- saving the document results in a white pop-up with no text (and no save), program then stops responding (you can only press esc to exit the white pop-up)
- all of menu items are absent, only white menus are present.
System log reads a lot of errors which start with a series of items like this:
 Microsoft Word: CGBitmapContextInfoCreate: unable to allocate 44304 bytes for bitmap data

When problem occurs, also a series of failures to network shares start appearing, forcing me to restart the Mac.

I have already tried:

- having my IT people carry out network tests (everything ok);
- checking for Flashback malware with FSecure instructions (not present in my system);
- re-installing Lion on a clean drive and importing only Timemachine data on the clean install
- re-installing Office from scratch (install performed by Apple service center)
- disabling autosave (in case there was a problem with autosave triggering
- disabling grammar and spellcheck

please find out a solution, I am routinely losing my work!

Eugenio
 

Question Info


Last updated December 15, 2017 Views 2,500 Applies to:
Answer
Answer
Important update:

my IT technician reports an important finding on the above issue:

network problems which were somewhat associated to the crashes were caused by my Mac being automatically assigned by Mac OS a network name which was too long (MacBook Pro of Eugenio...) and was seemingly not handled well by the Samba protocol of the Linux server.
This situation seems to have affected the Mac when working on files saved to the file server (perhaps the computer got too "busy" with network at times and could not handle mark-ups).
I shortened the name and things seem to have solved.
Also, since then, I can report no Word-markup crashes.
I have changed the name in Preferences->Sharing. this was the one which was allegedly causing trouble.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.