Office still displays fonts disabled using Font Book

My apologies if this question has been answered before. I did several searches and couldn't find anything.

I use a very small subset of typefaces: maybe 3-5 with Word and Excel and 6-8 with PowerPoint. I've disabled the fonts I don't need using Font Book, but even after restarting, they still show up in the Office menus.

I'm running the latest version of Office (14.4.6) and Yosemite (10.10.1) on a MacBook Pro retina display, late 2013.

 

Question Info


Last updated January 14, 2019 Views 781 Applies to:
Answer
Answer

First of all, open Applications > Utilities > Disk Utility, select your hard disk and repair permissions. This process will make sure that Apple-created folders and other infrastructure folders have the read/wrote/delete protections properly set for the system, the users and the applications.

After repairing permissions, restart your computer and test Word.

If Word still does not work, check the location of the fonts. There are three places where fonts reside:

1) Macintosh HD > Library > Fonts  (fonts for all users of your computer). This folder should contain a "Microsoft" folder that groups all Office fonts. Except for that one folder, it should not contain any other folder (you can create them for classification purposes, but I don't know what could happen if they end up having the wrong access permissions). The fonts here appear in Font Book's "Computer" category.

2) Macintosh HD > System > Library > Fonts (in general, reserved for the system). It should not contain any folders and you should refrain from adding or deleting fonts here. These fonts also appear in Font Book's "Computer" category.

3) Macintosh HD > Users > UserName > Library > Fonts (fonts available only to user UserName). To access this folder, go to the Finder, press Option and select Go in the Finder's main menu bar. As above, you should not have any unplanned folders in there. The fonts here appear under Font Book's "User" category.

______________________________________

When you disable a font through Font Book, it is moved to a folder called "Fonts Disabled" next to the regular "Fonts" folder, where the font becomes inactive.

Take a look at those three (or up to six) folders to make sure the disabled fonts appear in the "Fonts Disabled" folders and there are no stray copies in "Fonts." You can move them manually between those two folders, of course, instead of using Font Book, or move them between the other folders (be careful here!). You can also add and delete fonts (be even more careful!). In some instances you will be prompted for the user password.

Let us know how it goes!

_______________
If an answer provides a solution or you find it helpful, please mark it accordingly.

Si mi respuesta te ha servido, márcala como solución o como útil.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.