How can I get Word to omit words styled in a custom style when checking spelling?

Much of my 300 page document consists of foreign language words which have been styled in one of several custom styles. I would like to omit all of the foreign words from spell check, but checking the "Do not check spelling or grammar" box (Styles > Modify Style > Language) doesn't stick. When I check the box, click OK, and open Language again the box always reverts to a partially-checked state. I don't understand what this means. By partially-checked I mean the box has a flat line in it [–] instead of a check-mark. This is not the same as completely un-checked. 

The partially-checked option doesn't appear to do anything as spell check still prompts me at each of the foreign words. This is extremely frustrating as there are thousands of these words and fragments.
 

Question Info


Last updated December 19, 2017 Views 167 Applies to:
Answer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.