Office 365 University on Mac suddenly asks for activation

I purchased Office 365 University in May 2013 and activated it shortly after. Have used it since then without problems until the other day when it suddenly started to ask me to activate it. When I type in my product key, it says it is not valid. When I try to sign in to my Microsoft account, it says no such password but doesn't give me an option to recover the password. All the discussions I found online are not addressing my problem or are only useful for PC users. I want to talk to a real customer support person. How do I do this?
 

Question Info


Last updated September 8, 2018 Views 1,502 Applies to:

Can you post a screenshot of the pop boxes that come up?

There was an issue activating office but that had nothing to do with the product key.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft updated its verification - especially if you added 2 step, and even if you turn it off.

http://windows.microsoft.com/en-us/windows/app-passwords-two-step-verification

Had to find the above to fix the issue and then reactivate my account on the mac. Nobody on MS tech support had anything to say about this, and its frustrating this is only on a windows site that you wouldn't naturally look at. But it works. Outlook may not, but open word or excel and do it, then the whole 365 suite should function fine. Outlook gave me an error code, but word was allowed the password and all is well now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This really helped in that it encouraged me to sign in with my Windows Live ID. I had tried the email I used for the subscription but that was apparently the wrong thing to do. Word initially said there was not enough disk space for it to run but when I opened a document 5min later, it worked. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Glad you got it sorted, for the benefit of others, it would be best to mark Alind_101's post as the one that helped you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.