Error after installing Service Pack 2: Your identity is older than this version of Outlook

I just  updated to latest outlook. (14.2.0)

When I try to run outlook it asks to 'Please upgrade the Office database'.

Pressing 'Upgrade' I get: 'There is a problem with the Office database...  rebuild it using the database utility.'

Pressing 'Rebuild' the MDU opens and starts step 1 of 5: scanning... and gives the message: Your identity is older than this version of Outlook. Please rebuild by using the last version of Outlook that used this identity.

Not sure what to do?  Do I need to somehow install an older version of outlook?  If so where can I get it?

Thanks
-J
 

Question Info


Last updated April 16, 2019 Views 14,510 Applies to:
Answer
Answer
Hi everyone!

Microsoft has just released the 14.2.1 update which can be downloaded using the link below:


If you're still experiencing an error that says "Your identity is older than this version of Outlook. Please rebuild by using the last version of Outlook that used this identity", please download and install the 14.2.1 update.

If you are still unable to upgrade or open Outlook for Mac after installing the 14.2.1 update, I recommend creating your own thread so that myself and the rest of the community can focus on your specific issue. You can do this by choosing Ask a question at the top of this page.
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.