Why does my decimal separator change when creating charts?

Hi,

I use the Dutch version of Excel 2011 for Mac and have a problem with the decimal separator. I changed the decimal separator in my system settings a while ago, so that commas are the decimal separator and dots are the thousand separator. This works perfectly fine when I type data and make calculations in excel. However, when I create charts from the data in my excel sheet, the numbers on the axis use dots to separate decimals instead of commas. What is going wrong?

And how can I make the charts' axis use the same decimal separator as the data in my sheet?

Help is very much appreciated.

Regards,

Casper

 

Question Info


Last updated November 16, 2018 Views 631 Applies to:
  1. Remove chart (if that small) then save document.
  2. Quit excel
  3. Go to system Preferences
  4. Language & Regions
  5. Click on advanced you will see this this:


  6. Set item Marked
  7. click okay
  8. Now Open your excel document and create yor Chart.

See if shows correctly now.

__________
Disclaimer: The opinions & answers are solely mine and mine alone, and do not necessarily reflect upon my position as a Community Moderator.

If my reply has helped, mark accordingly - Helpful or Answer
Phillip M. Jones, C.E.T.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your answer! Unfortunately, that does not solve the problem. Changing those system settings is what I did earlier. Works fine for every program and every task I perform in excel, except for creating charts. When I create a chart it suddenly uses dots as decimal separator and commas as thousand separator, regardless of how I set my system preferences.

When I right click on a cell and click on 'format cell' it shows the correct format with a comma as separator:

Tried quitting, rebooting, updating to latest version, etcetera. Did not solve the problem. Are there perhaps other language preferences or settings in excel that I am missing here? Or is it a bug or something?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi! Did you fix that?

I am heaving the same issue on office 365 - mac and it's driving me crazy.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.