Mac Excel converts UTF-8 characters to underlines during Data -> Text > Import. Is there a workaround?

I am trying to use the Text Import wizard to import a csv file encoded in UTF-8.  When I go thru the wizard, choosing UTF-8 as the encoding, Excel turns all the accented characters to underlines.

The same import with a UTF-16 LE encoded file seems to work fine.  

Is there a way to import UTF-8?

Thanks,
Paul
 

Question Info


Last updated December 17, 2018 Views 20,044 Applies to:
Answer
I converted my file to UTF-16 Little-Endian, as suggested, and was able to import successfully. For anyone else who needs this work-around, I used TextWrangler (free app from Bare Bones Software) to do the encoding change.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Here's another work-around: Get OpenOffice which is great, free, available for Mac, etc. Import your file. Save as Excel format. Bob's your uncle.

More details: The TextWrangler option also worked for me. What did NOT work was using the command line "iconv" tool. It converted the file just fine, but did not create the BOM (byte order mark), which, apparently, excel on the mac must have. There is apparently no way to get iconv to create the BOM.

F.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.