Workaround: Edge Crashing With Roaming Profiles Enabled

Hello Insiders!

As you may have noticed in today's blog post for the 14279 PC flight, we've fixed an issue from an earlier build where you may have experienced crashes with Edge and possibly Cortana for roaming user profiles on your PC.

This fix will prevent any additional occurrences of this bug, but may not fix an already broken roaming user profile.

For users with affected profiles and who are handy with PowerShell, you can run the following commands to bypass the issue:

reg delete "HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage"

 

Get-appxpackage -packageType bundle |% {add-appxpackage -register -disabledevelopmentmode -ForceApplicationShutdown ($_.installlocation + "\appxmetadata\appxbundlemanifest.xml")}

 

$bundlefamilies = (get-appxpackage -packagetype Bundle).packagefamilyname

 

get-appxpackage -packagetype main |? {-not ($bundlefamilies -contains $_.packagefamilyname)} |% {add-appxpackage -register -disabledevelopmentmode -ForceApplicationShutdown ($_.installlocation + "\appxmanifest.xml")}


Note:  This fix may cause minor data or settings loss, such as your Edge customizations. 

We're looking at potential resolution steps for users who may not be familiar with PowerShell.  I'll provide updates should they become available.


Thank you as always,
Jason

 

Discussion Info


Last updated June 28, 2019 Views 8,779 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

When will this be patched via Windows Update? This is the last bug I need to see fixed before I will roll out Windows 10 on our 50 computers.

When will this be patched via Windows Update? This is the last bug I need to see fixed before I will roll out Windows 10 on our 50 computers.

Are you planing to roll out the preview to the 50 systems? or are you going to use the RTM build 10586.122, as you are posting on the Insiders/Preview site which is for testing of BETA software and not to be used on everyday systems.

 What is your question and what do you want patched? as the poster has posted info about a bug fix.

I'm a unpaid independent Advisor/volunteer

Wow Microsoft claim to have fixed a serious bug they introduced in the November update and it only took them four months to do it.

I cannot take Windows 10 seriously with this level of support.

I posted this issue on the TechNet forums back in November last year, and would like to link to this topic there. However, the topic is locked and I cannot add a reply there.

Since the TechNet topic has 100+ replies and 10,000+ views, it might be good to reopen the topic and post a link to this topic over there. Does anyone have tips on how to let that topic be reopened? The wiki says that there should be a button "Unlock Thread", but I cannot find it.

Jason,

Any idea if the fix gets back ported to 1511 (10586.122) with an update or hotfix?

Thanks for getting the fix in the latest preview builds.

Ryan

This did work while in the current session, Edge opens now but if we log off the machine and back on again, the edge window opens, then closes again. So just the same as before. Edge still will not open on machines with Roaming profiles.
This solution is only permanent if you are on build 14279, which is currently just available for people in the Fast Ring. If you have a previous build (<14279), you will still experience this problem after logging off and on again.

Agreed. My main Windows 10 computer is still gimped because of this known bug. I cannot even begin to think of a Windows 10 company rollout until I can vet that systems will not experience the same issues as mine. I do not consider this fixed until it is baked into the OS and released as a new ISO which can be used for rollout.

Microsoft should make the 'free' Windows 10 upgrade permanent, and not just a 1-year window, when MS can't even fix major known show stopper bugs for enterprise within the first year.

I run this solution on Windows 10 Pro build 10586.164 (roaming profile on domain), now everything is working perfect!!

(fix Edge, Cortana, Money, News that quit on opening)!

Thank you very much!

Remember to run Powershell with admin privileges!

Update: Sorry, but once rebooted the problem persist!

Isn't this just removing all the registry settings of your Modern Apps and reinstalling them? Isn't there another way to solve this issue with preserving the settings?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.