windows socket registry entries missing according to diagnostics and internet no longer working at all

I updated to w10 tech preview on my acer w700 tablet.  All seemed to be working.  Then windows performed an update KB3034229.  The update required a restart.  Then the problems started.

1. The computer recognized my home wifi as a PUBLIC network.  I was unable to convince windows firewall that it was indeed private.  So, I turned off Windwosw firewall.  Eventually I managed to show the network as private.

2. To cement the change I rebooted.  Unfortunately this resulted in the network being reset to public with no internet access.

3. After much trial and error and diagnostics, I received:  Windows socket registry entries required for network connectivity are missing.

4. I have tried uninstalling this update but that didn't work either.

How can I fix this problem? Without Internet I can not download any updates.  I am entering this from my laptop.



Hi Allanah, 

It seems that the actual registry entries are possibly corrupt. This may have affected TCP/IP as well and you say you have tried the reset cmds to no avail so I would try repairing them instead. Just so you know, this is considered a manual winsock reset of sorts, and involves modifying the registry. Please backup the full registry before you ever touch it. Also backup/export keys that you are intending to modify or delete. Thanks. So the main goal is to use the registry editor to delete (backup first!) the winsock and winsock2 subways and then remove and reinstall TCP/IP on Windows. To do this, follow these steps:

1) Start > Run > type "regedit" > hit enter.

2) Locate the following subkey:


3) Right click and delete the entire Winsock key and the Winsock2 keys.

4) Close regedit. 

Now, re-install TCP/IP overtop itself (it's a core component and can't be uninstalled, so we improvise..)

1) Login as admin. In control panel open up, "Network and Sharing Center"

2) Right click "Local Area Connection", and then click "Properties"

3) Under the This Component Uses the Following Items dialog box, click Install

4) Click Protocol, and then click Add

5) Click Have Disk

6) In the Copy Manufacture's files from box, type C:\windows\inf and then click OK.

7) In the list of protocols, click Internet Protocol (TCP/IP) and then click OK. Restart computer.

Let me know if this helps.

58 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated December 11, 2020 Views 320,756 Applies to: