Cannot set cellular data to metered connection! Option is permanently off!

I apparently am unable to set my Cellular data to metered. The switched is apparently grayed out  for whatever reason. My data is being expended like crazy and I do not know how to turn it back on to metered. What seems to be the problem and what should I do?

 

Question Info


Last updated May 6, 2019 Views 17,043 Applies to:
Answer
Answer

Think I've managed to sort this one out:

The values for metered or non-metered are stored in the registry keys (to be noted the solution was tested on W10 x64 Ent edition).

Logical explanation would be that when the drivers for the WWAN cards are installed, either when W10 is setup or afterwards (depends on what you chose), the drivers are installed under trustedinstall account, and that account remains the owner for the registry values and will block any changes to those keys regardless if you are the local admin or user accounts.

In order to make changes to those registry keys you should take a backup of your registry, change the owner of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\DefaultMediaCost key to your account and set 3G and 4G values to the whished output (1 for non-metered, 2 for metered). Once done, reboot the machine and you will obtain the desired effect.

I started working on this after changing from the toggle button the WWAN connection to metered - off but Outlook 2013 when starting still saw the connection as metered.

In theory it's a registry key permission issue, if you would change the owner either to System or Users to allow changes to those registry values, when toggling the button in the GUI you would also see the change in the registry for the values between 1 and 2, but I do not know how that GUI management was designed by MS and I did not take the time to test it further, although MS should release probably a fix for it if it's a design issue.

Let me know if it works, although it did the trick in my case, the short steps would be:

1. take a backup of your registry;


2. change the owner to administrator/ users or any other account you are working with for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\DefaultMediaCost

3. set the desired values for 3G and 4G keys to 1 for non-metered or 2 for metered

4. restart the machine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Reifenwerfer,

It is set to metered by default for 3G & 4G connections. 

You will find out the current state of yours when you look at that Registry key.  Once you've taken ownership of the key, it just takes a moment to change.

It is possible that your Registry key was changed by whatever fault in the UI made MS remove that facility but that's just speculation on my part.

You will need to keep an eye on the value of the key in future as some major Windows updates replace the Registry and do not transfer unexpected settings.  I am going to try to automate this check using an elevated batch file [run within Task scheduler using a network connection trigger from Event viewer] but I don't expect to have the time yet so here are the commands I envisage in case you want to have a go yourself

1  Run this command - reg export HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\DefaultMediaCost D:\Desktop\KeyToCheck.txt

2  Use FindStr command to detect the line "3G"=dword:00000002 in the text file {i.e. the line showing that the value remains set correctly}

3  If the line has been reset {i.e. FindStr returns an error}, run a notification to tell you - I will run a vbs MsgBox but that's just because I am already in the habit of using vbs for all such notifications.

I'll keep a link to this thread so I can post the final version of my checking facility but I do not know when that will be as I'm pretty tied up at the moment.

All the best,

Try*3 - a user
Dell Inspirons 7779, 1545, 9300; Windows 10 Home x64 & Pro x86; Office Pro 2007; HP DJ2540; HTC UPlay [Android 6.0], MyPhoneExplorer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.