Cannot config static IP

Network Properties

Change Adapter Settings

Ethernet Properties

Internet Protocol Version 4, properties grayed out.

I need to set this as a static IP. Please fix

 

Question Info


Last updated July 21, 2019 Views 9,733 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

goes for IP version 6 too, sadly. My servers are all IPV6.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Network Properties

Change Adapter Settings

Ethernet Properties

Internet Protocol Version 4, properties grayed out.

I need to set this as a static IP. Please fix

I can't even get that far. I get an error soon as I pick properties.😢

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Each build gets worse then the next. Unbelievable isn't it.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Which build?  If you are on 10041, reinstall the Network Adapter driver.  Since 10049 has been released you might just go to that to see if it is any better.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Build 10049

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just did a clean install of 10041 and was unable to join my laptop to the domain. I do not have a TPM chip on this laptop. Windows Update allowed me to update to Build 10049 however I am unable to join the domain and my ipv4 and ipv6 properties are greyed out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This thread is starting to get mixed between the Adapter Properties issue in 10041 and the TCPIP v4/v6 Properties issue in 10049.

As you have pointed out, its relatively easy to fix in the former case.

For the latter case, I would strongly urge anyone using static IP addresses who hasn't updated to 10049 yet to stay in the Slow Ring in hopes that a fix is coming soon.

See additional THREAD for more info.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

check the addition thread, seems you provide the more suitable answer thanks      

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

MSFT has updated the TechNet forum thread with an explanation of the issue and expectations for correction.  Please see it HERE

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Build 10049

I fixed my issue (I needed to set different DNS servers) with this command line in PowerShell:

Set-DnsClientServerAddress -InterfaceAlias Ethernet -ServerAddresses xxx.xxx.xxx.xxx, xxx.xxx.xxx.xxx

I was starting to try setting via netsh but got this message:

netsh>dnsclient
In future versions of Windows, Microsoft might remove the Netsh functionality
for DNS Client.

Microsoft recommends that you transition to Windows PowerShell if you currently
use netsh to configure and manage DNS Client.

Type Get-Command -Module DnsClient at the Windows PowerShell prompt to view
a list of commands to manage DNS Client.

Visit http://go.microsoft.com/fwlink/?LinkId=217627 for additional information
about PowerShell commands for DNS Client.

Get-Command -Module NetTCPIP will find all the commands for setting the static IP address.

Don

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.