[FIX] Windows 10 and network share problems.

I had interesting issues after I changed the Windows 10 login account type from local to network one.


All of my samba/cifs shares didnt work after the change.

I tried googling around alot and most of the suggestions were only about using register hack that in my opinion is the wrong way to go and leave your system vunerable for attacks.

I found a fix with windows own tool and now all my shares work as intended without any extra hassle.

All you need to do is go to Control Panel -> Credential Manager -> Windows Credentials



Select Windows Credentials

Internet or network address : your samba/cifs servers IP or name (like: MYSERVER)
User name : The users name on server with access to the share
Password : password of the user

after you've pressed OK, the network shares / drives should start work like before without any register hacks.

At least this worked for me like a charm *^_^*

update: Make 2 credential files one for IP address and one for Hostname.

 

Discussion Info


Last updated December 6, 2019 Views 67,234 Applies to:

I am unable to get my samba/cifs shares to work in Windows 10.  We are using samba4 on Centos 6.5.

The samba/cifs shares were working before I upgraded to Windows 10.

I followed the steps above and still can not access the samba/cifs shares

This does not work for me.

I have tried everything I can find.  

I have build 10240 now.  Windows 10 Home.  Is it the "Home" that is problem?

Why, why is this issue persisting?  My wife's brand new MacAir has *no* problem with mapping and (re)connecting.

Can someone from Microsoft simply fix this and tell me exactly how to do it?

Mike (very frustrated) Vermace

Not sure if this is my issue but ill explain:

I use Openelec as a HTPC OS and my Windows 10 PC acts as the server with Kodi 15.X and mysql for database syncing.

on 10240 i had no problems with openelec finding the SMB shares from my PC.  after updated to any builds since 10240 i only get partial SMB access.. sometimes items show up in the browser on kodi's filemanager via SMB, and sometimes they don't, maybe its a coincedence maybe its kodi, maybe its openelec.  I have not tried any other linux to try to read the shares on the Windows 10 PC.

I also posted on openelec and kodi forums.

I have created the credential for what the login/pw for the server address is (192.168.1.199) local only.  But it doesn't seem to affect anything.

Thanks in advance

your server has static ip address? Try make 2 credentials. One with IP and one with hostname?
enjoy the force of life

Amazing!!!  I had to reinstall Win10 on the third machine I upgraded from Win 8.1. After a month of successfully using network shares and NAS (old Terastation), it wouldn't boot up. Tried everything, failed, finally did new complete install of Win10 losing all my files yesterday 12/4/15.

This new Win10 update, (yes, I saved the product key, luckily, and reinstalled with the TechBench ISO) 12/4/15 did NOT work at all like the October Win10 install. This one would not work seamlessless with the old NAS like October version (sorry I don't know the build numbers.  All my upgrades were the online upgrades).

Anyhoo, I added Samba1, and a few other things that the successful Win10 machines had and still could not connect. That's when I found this website THANK YOU that mentioned CredentialManager. I compared working Win10 machine with the nonworking machine and the nonworking machine had a Windows Credential already, but the 'good' machine did not. So I deleted the item in CredentialManager and now I can connect to the old Terastation NAS from this one to.

Thanks for saving my sanity this week!! I'm sure Win10 will cause problems next week, but NOW IT IS WORKING.

p.s. like others, to share other actual computer hard drives, I have had to resort to giving local access to Everyone. The problem is that even tho I used the same user on each machine, Win10 seems to regard them as different people.

After several weeks of trawling the internet this fixed the issue for me.