Windows Insider Preview 14905 breaks bash

I signed up for the Windows Insider previews prior to the release of the big anniversary update as I am a web developer and having the bash command line support is phenomenal. I used VirtualBox and vagrant for quite some time. It was annoying but each build update I would get I would have to re-download my vagrant box so that it would boot up properly. So then it finally broke to the point where it wouldn't boot at all and everything I tried would not work. So I made the full switch to essentially running a LAMP server on bash instead. Now I get this build and I cannot open bash command prompt. It worked last night when I left work. It updated over night. I sign in and go to open it and nothing.

If you happen to know why this is, and more importantly how to fix it I'd love to hear it.

Interestingly, if you open windows command prompt and type it "bash" to try and run it there I get a line that says "Error 0x80070005". Again, not sure if this helps. My google (or Bing!) search of this error says it's a permissions problem but I've still been unable to resolve it.

Thanks in advance!

Craig

EDIT: Just went to restart my PC and when I click on the start button and then click on the power button icon the start menu just disappears and I am not presented with the option to shutdown or restart. If I do a CTRL-ALT-DEL and go to that screen I can click the power button and get the options however... annoying but workable.

 

Question Info


Last updated May 18, 2018 Views 87 Applies to:

"... If I do a CTRL-ALT-DEL and go to that screen I can click the power button and get the options however... annoying but workable."

..Yes, a bit annoying. Maybe the next build will fix it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Got it working again! Keep in mind that my bash was open with services running when windows decided to install the update and reboot my machine. So bash probably didn't shut down those services or close properly in that case which is maybe how I ended up here.

This is PROBABLY the only step I did that was necessary:

Hit the Win(windows key) + R to open the run command. Type in C:\Users\<useraccount>\local\lxss\temp and hit Enter key or click Ok. Delete the temp files in this folder. Now try running Bash again, it should work!

These are the steps that I did leading up to the discovery above, in case the solution above does not work for you!

First alternate step:

So first thing I did was open c:\Users\<username>\AppData folder. Right clicked on the Local folder (this is where the Lxss folder for bash is very well hidden), clicked on Properties, clicked on the Security, I then clicked on the Edit button,  I clicked on Add and in the text box I put Everyone and clicked Ok. Then I clicked the box for Full Control. Click Ok. Then it will replace permissions on all the files, if you have an AV program installed expect some files that you cannot change permissions to.

Second Alternate step:

In that same Properties->Security window from above, click on your user account, click Advanced. Again, click on your user account and then click on the check box that says "Replace all child object permission entries with inheritable permission entries from this object". Click Ok. Let it do it's thing and when it's done reboot.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The power shutdown option is a known bug if you read the release notes for the latest preview build 14905. The recommended work around is to right click Start and select Shutdown or sign out then Shutdown.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.