Windows Update Error 0x80004005 - 0x20004. Help please!

I currently have Windows 10 Home Insider Preview Build 10074 and I was trying to update to build 10130, but whenever I start installing the update it stays at 0% and soon after my laptop restarts and it goes to the last build, in this case 10074. When my laptop has restarted and I have signed in to my user, I get an error message with code 0x80004005 - 0x20004.

 

Question Info


Last updated July 16, 2018 Views 2,942 Applies to:

Hi ZenderX,

Thank you for posting the query on Microsoft Community.

I am sorry to know that you are unable to upgrade to 10130 build. Do not worry, will assist you with the issue.

Disconnect all external devices except Mouse and Keyboard.

Try to disable any security software installed and then try to install.

When you disable Antivirus:

Important Note: Antivirus software can help protect your computer against viruses and other security threats. In most cases, you shouldn't disable your antivirus software. If you have to temporarily disable it to install other software, you should re-enable it as soon as you're done. If you're connected to the Internet or a network while your antivirus software is disabled, your computer is vulnerable to attacks.

 

If issue persists, the try to install it in Clean Boot.

This helps eliminate software conflicts that occur when you install a program or an update or when you run a program in Windows. It starts Windows by using a minimal set of drivers and startup programs.
How to perform a Clean Boot in Windows: http://support.microsoft.com/kb/929135


Note: After troubleshooting, refer to this section "How to reset the computer to start normally after clean boot troubleshooting" in the above link. (Applies to Windows 10 also)

  

Hope this helps in resolving the issue. If issue persists, do get back to us. We will be happy to assist you.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I disabled my antivirus and it didn't help. Also I tried the clean boot but didn't work. I tried to install build 10130 but now I got this error message:


Translation "Couldn't install Windows 10 - 0x80004005 - 0x20004, Installation failed on SAFE_OS, because of an error during INSTALL_RECOVERY_ENVIRONMENT" not the perfect translation because English is not my first language. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I received an error 0x80004005 from the settings app whenever I tried to upgrade to a new build. I could clean install the new build, but then subsequent builds would give the same error when Windows tried to install them as updates. The only description I could find on error code 0x80004005 was a generic "Access denied".

I finally resolved the problem by changing the partition style of my system disk from MBR to GPT. (Note that my system is UEFI based.) Your error refers to the Recovery Environment, which Windows installs to a unique type of partition on a GPT disk. While your error adds code 0x20004 (I did not have that extra code), I suspect that your error is still related how your disk is partitioned.

You can check your partition style by opening Device Manager, expanding Disk Drives, and double-clicking the disk where you have windows installed to open the Properties dialog. Then switch to the Volumes tab and click the Populate button. You will see either GUID Partition Table (GPT) or Master Boot Record (MBR).

If your disk is partitioned with the MBR style, I recommend that you change it to the GPT style. That may fix your 0x80004005 error. The new builds of Windows 10 installed normally through Windows Update after I converted my system disk to GPT.

The Windows DISKPART command-line utility has a CONVERT command that allows you to change the partition style, but it will destroy all your data in the process, and you will have to reinstall Windows. DISKPART can also be confusing and dangerous to use. One wrong command can destroy all your data. I do not recommend using DISKPART unless you already know how to use the utility and have a good understanding of disk partitioning and windows administration.

If you feel comfortable using third-party software, I had good success with a utility called AOMEI Partition Assistant that was able to convert the partition style to GPT with all my data in-place. There is still a risk of data loss if the process fails (due to an error, power loss, etc.), so I strongly encourage you to make backups of anything important.

If your disk is already using GPT, then you might have errors in your partition table. A typical GPT disk with Windows should have a small recovery partition (mine is 449 MB), a smaller EFI System partition (mine is 102MB), and the rest of the space should be partitioned to NTFS (the C: drive). You can check Windows Disk Management or AOMEI Partition Assistant and see if your disk resembles that description. If it doesn't, please post a screenshot of what it looks like and maybe I can advise you from there.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Microsoft have released the latest Build 10240. I would suggest you to install the latest Build 10240 and see if that fixes the issue.

Build 10240 now available for Windows Insiders in Fast and Slow rings
http://blogs.windows.com/bloggingwindows/2015/07/15/build-10240-now-available-for-windows-insiders-in-fast-and-slow-rings

Hope this helps. Let us know if you have any other issues with Windows in future.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.