After installing creator update, NUC failed with 0x80070057 on Win activation, store download and win update

After updated to creator update using the media creation tool. The windows update no longer works, always failed with 0x80070057. Tried use troubleshoot to fix it, problem remains. Try download any app from windows store, failed with the same 0x80070057 error instantly.

Try format the hdd then do a fresh install of creator update, big problem straightaway. Windows activation no longer works, failed with the same error of 0x80070057, win update and store same problem.

Hardware is stock standard Intel NUC 5i5RYH with WiFi and Ethernet. Only Ethernet is connected, IE/Edge works fine.  Wifi driver is loaded but not connect to any access point. Try disable everything in Proxy setting, same problem. Tried disable firewall completely, same problem.

Restore to build 14393 everything works again. I notice at the last leg of installing 14393, the windows installer ask for which network to use (in Creator update it never asked).

EDIT: 20/04/2017. As reported, my original issues are resolved by updating the bios to the latest intel NUC bios. However, problem remains on many other users who are with different model of NUC.


Question Info

Last updated January 5, 2020 Views 11,464 Applies to:

I might have cracked it. The Intel NUC doesn't have a Serial Number set in the BIOS. I used the Intel Integrator Toolkit (ITK) to set the serial number, SKU and Manufacturer and my Windows 10 Creator is now Activated and Windows Update works again.

I must admit, I tried a few other things before that, so I hope it is not a combo of things. But once the serial number etc was set, one reboot Activated my Windows 10 Creator.

I hope it helps anyone...

... Naplutetium

PS, I have the DN2820FYK

Edit 30/6/2017: Several people mentioned that they only had to do a BIOS update to fix this issue. In my case, I was running the latest version (I believe the DN2820FYK is end-of-life). So, if you have a NUC with a newer BIOS version, try to update the BIOS first. If that doesn't help, read on...

Edit 27/4/2017: kulmi84 , DougHo and others confirm that they only needed to download and use the ITK to change the system manufacturer and system product and reboot.

ITK6.efi -s -t system -f manufacturer -v "Intel Corporation"

ITK6.efi -s -t system -f product -v DN2820FYK

Consider the rest of this post as FYI.

Edit 20/4/2017: Some more info on the steps I followed to find above solution. I do this from memory and have no way to reproduce it, so forgive me if some steps are not accurate or some are missing. Just ask if you have questions. Not all steps might be needed, but this is what I did:

  • In the Activation Windows Screen, you will see an error message that it couldn’t Activate. Lower down in the same window there is a Troubleshoot link. When you click this link a new dialog pops up.
  • This dialog will time out quickly with an error message. Something about “Got interrupted, please make sure you are connected to the internet”
  • In the same dialog there is a link which says “Did you recently changed hardware”. Click it.
  • This will show another window which asks you for the Microsoft Login details. Enter the details and you will end up in your profile at Microsoft.
  • According to MS: “In Windows 10 (Version 1607 or later), you can link your Microsoft account to the Windows 10 digital license on your device. This can help you reactivate Windows using the Activation troubleshooter if you make a significant hardware change later, such as replacing the motherboard.”. I never had 1607 running (skipped it since it bricked the NUC). More details here:
  • After I logged in there is a list of Devices which are linked to your account. Since I have two other Win10 devices I followed the steps in above link to Link these devices to my account. I then noticed the NUC in there as well, however, the Serial Number was YYYYYYYYYYYYYY. The serials and all details of the other devices were fine. I didn’t like the NUC Computer Name (something like DESKTOP-123455) so changed the Computer Name too (just one word, no dash). Not sure if this is important.
  • Please note! Once you enter the details for your MS account, this is used to login to your computer! No longer a local account if you were using one
  • I Googled more info on NUC serial numbers and found they are not set in the BIOS. To “Identify Your Intel NUC”  I went here: These are the details I used in the ITK.
  • I found a way to show the version details of the NUC in Windows here (albeit for a different version of the ITK). For example: It showed a blank serial number here too.
  • I downloaded the latest ITK from Intel and followed the steps in the pdf which is included (can add more details on request).
  • I rebooted the NUC into the BIOS (F2) and found the System Information page. It also has the serial number missing (this screen is a little hidden, click the blue/white balls in the bottom of the Main screen)
  • I also went to the Boot Configuration screen (in the Boot tab) and changed the OS Selection to “Windows 8.x/Windows 10”. By the way I am running the latest BIOS.
  • Also, in the Boot Devices pane, I enabled Internal UEFI Shell (as needed to run the ITK).
  • I saved the BIOS settings and rebooted again, pressed F10 to boot from the USB.
  • Then I followed the steps in the ITK PDF to enter the missing details. You can enter ITK6.efi -s -p to show you the current details. They were blank for me. I then entered teh following commands. The SKU and Serial number are from the “Identify Your Intel NUC” link above (sticker underneath the device).

ITK6.efi -s -t system -f manufacturer -v "Intel Corporation"

ITK6.efi -s -t system -f product -v DN2820FYK

ITK6.efi -s -t system -f serial -v <mySerial from sticker>

ITK6.efi -s -t system -f sku -v <mySKU from sticker>

ITK6.efi -s -t system -f family -v NUC

ITK6.efi -s -t chassis -f manufacturer -v "Intel Corporation"

ITK6.efi -s -t chassis -f serial -v <mySerial>

ITK6.efi -s -p

EDIT 21/4: Corrected ITK6 commands based on leonkernan's feedback

  • Rebooted again, went to Windows Activation Screen and “Viola!” It now says something like "activated with digital certificate" and fixed the Windows Update.
  • I went to MyAccount and checked the devices and the NUC now has the correct details.
  • EDIT 23/4: some mention they require two reboots, others say that it takes a while (5 - 10 mins) for Activation to happen.

Hope it helps even more?

94 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.