How to disable "display scaling on high DPI devices" for ALL programs?

I installed Windows 10 on my laptop, previously having W7 on it, and was at first very confused why all of my programs looked incredibly blurry. I have since discovered that the culprit is the "display scaling on high DPI devices" "feature" on Windows 10. Not a single program I have used (several dozen thus far) displays un-blurry text unless I right click the shortcut, go to compatibility, and choose "disable display scaling on high DPI devices."

I don't know what this "feature" is supposed to do, but it doesn't work, at all. How can I disable it system-wide instead of having to disable it for every shortcut individually?

Thank you.

 

Question Info


Last updated March 3, 2020 Views 71,891 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for your interest in Windows 10 Technical preview.

Unfortunately there is no such option to disable DPI for all programs. I would suggest you refer the link below for more information.

https://technet.microsoft.com/en-us/library/dn528847.aspx?f=255&MSPPError=-2147217396

Note: The troubleshooting steps in the above link is meant for windows 8, however, you can use the same for windows 10 tech preview as well.

Hope this information is helpful. Please do let us know if you need further assistance, we’ll be glad to assist you.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

    You can't disable this “feature”.  In Windows 8.1, Microsoft removed the mandatory "XP style scaling" option and made the compatibility scaling method the default, even though most programs display fine at higher DPIs.  VERY BAD DECISION.

    In Windows 7 with XP Style Scaling enabled, it just worked fine for most programs.  IMHO, the compatibility scaling mode should be off by default, being instead an option we turn on for programs that don't display correctly.  Currently it is backwards, with the compatibility mode being on by default, causing all programs that don't specify their compatibility to appear blurry.

    On their own page (linked in Sara Mohammedi's post above), Microsoft shows users how to manually disable the compatibility mode scaling for each affected program, tediously, one by one.  Of course, without the Start Menu (thinking of Windows 8), it is very hard to get to that Properties dialog in the first place.  Because of this issue, some time ago I wrote a program that makes it easier to enable the high-DPI compatibility flag on certain programs quickly and efficiently.  Perhaps it will help out in your situation.  You can download the latest version here.


Dear Microsoft, please make Windows 10 functional, pretty & intuitive, not boring, clumsy & buggy!

114 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is crazy and needs to be disabled by default.

Even programs like command prompt show up totally blurry!

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I literally have to disable DPI scaling for nearly every program on my computer?

I have a 1080p display on my laptop, it's not a super high resolution display. If Microsoft programs such as command prompt aren't DPI aware, how can you expect every other program from 3rd party vendors to be?

I think it's a good idea to push for vendors to support high res displays, but blanket-enforcing DPI scaling in all applications when 99% of them don't support it is just ridiculous.

:-(

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If it helps any, on my system I noticed my Display had gone to a magnification of 150% in Display Settings.  On one of those occasions, the slider still showed 100% so I moved it to 150% and then back and the screen returned to 100%...

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

    The worst part is that while most programs support high-DPI just fine (or acceptably well), they don't report that they are high-DPI aware.  So now we have all these programs out there that were originally made to be high-DPI aware but were written before the new high-DPI awareness reporting became a requirement, and now Windows 8.1 (and 10) enables the compatibility DPI scaling mode for all these non-reporting programs unless manually told otherwise (with the Compatibility tab option as described in my first post).  What changed is Windows now assumes that all programs do not support high-DPI unless they specifically report otherwise.
Dear Microsoft, please make Windows 10 functional, pretty & intuitive, not boring, clumsy & buggy!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Mine is set to 125%. I just tried changing it to 100% and the text in programs became insanely small (way smaller than it ever was in Windows 7).

I don't know what M$ is doing here, but they need to figure it out before the W10 launch or there are going to be a lot of unhappy users!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

    Yeah, you're telling us how to turn high-DPI off, but some of us have difficulty seeing content scaled at 100% (96 DPI) because of high-DPI screens, or a large screen set far away from us, or poor eyesight, and we have high-DPI switched on on purpose.  When then?
Dear Microsoft, please make Windows 10 functional, pretty & intuitive, not boring, clumsy & buggy!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I completely agree this is a major problem.  For applications like Flixter the scaling makes the movies unwatchable.  50% of the movie is off screen and the remaining part is blurry.  The compatibility tab is missing for the Flixter application and there is no setting to disable the scaling for the application. 

The default for my screen is 125%, which displays items and fonts properly in Windows 7 and most things in windows 10.  Moving the scaling slider to 100% makes Flixter work but everything else is becomes too small. 

Scaling must be off by default not on.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah this thing should be off by default, everything works just fine with it off and now everything are just screwed up because of this stupid feature. MAKE THIS OFF BY DEFAULT! PLEASE! God damn this thing is pissing me off.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.