Runtime Broker and Antimalwear high resource usage.

When I start the computer Runtime Broker seems to run for 10 to 15 minutes and take over the hard drive. This bogs the system down. Then the Auntimalwear kicks in along the way and disk usage jumps to 100%. All this cpu, memory and disk usage causes temps to go up in the system also. I have concerns that this could in the long term hard my system hardware. If I use task manager to stop runtime broker things goo good until I leave the system idle for a few minutes and then it starts up again. I have gone through the forum and have run all the diagnostics and fixes suggested to no avail. I have uninstalled all the store apps that were on the system and turned all active tiles off.  I notice that I am not alone in this problem but there has been no clear fix for it. If it remains after the final version on July 29 I will simply go back to Windows 8.1 until Windows 10 is fixed. Someone please explain in plain English what runtime broker does !! How the heck did Microsoft put such a re3sourse hog in Windows 10. Thanks for your time.

Mike

 

Question Info


Last updated August 15, 2019 Views 42,474 Applies to:
Answer
Answer
Runtime Broker kept thrashing my system, usually using 40% of my CPU although memory use wasn't much, according to the Task Manager. I'm currently using Windows 10 Pro x64 version 10240.

Runtime Broker is a service called Time Broker, which can be disabled through editing the registry.
Right-click on the Start Menu Icon. Go to RUN and type regedit.exe and select OK.

Find the following entry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003

Change the 3 to a 4.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup.

Before editing, the original value was 3. Set to 4 to disable. Just change the 3 to a 4 through the MODIFY menu selection, exit regedit and reboot your system.

After this edit, Runtime Broker no longer runs and the CPU at idle is now only 0 to 1 or 2 percent.

No adverse affects after disabling Runtime Broker on my system.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.