0xc0e90002 error

After installing Windows Insider Preview build 16193 I am getting a BSOD 0xc0e90002 unexpected error has occurred.

WIndows10  installation media can not boot and PE also to .

Installing Windows8.1 no problem.Try to upgrade from windows8.1 to windows10, the same 0xc0e90002 error.

I need your help, I would like to use windows10 system, thanks.

I am from China, English is not good Please understand.

Attach a screenshot:

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated November 11, 2019 Views 4,830 Applies to:
Answer
Answer
Hello,

I got into a similar issue. In my case, it's much worse and I couldn't see even the error code. But, anyway, I debugged it and found this is caused by "Revoke" information stored as EFI variables. It's most likely to be an OS issue.

Here is the steps to delete the "Revoke" information from your PC. Once it's done, you should be able to re-install Windows 10.

1. prepare a USB flash drive (with capacity less than or equal to 32GB)
2. format it with FAT32 file system
3. download the EFI Shell, Shell_Full.efi, from Github
   https://github.com/tianocore/edk2/tree/master/EdkShellBinPkg/FullShell/X64  (if you're using 64bit OS)
   https://github.com/tianocore/edk2/tree/master/EdkShellBinPkg/FullShell/Ia32 (if you're using 32bit OS)
4. rename the filename of the EFI Shell
   rename it from Shell_Full.efi to bootx64.efi  (if you're using 64bit OS)
   rename it from Shell_Full.efi to bootIa32.efi (if you're using 32bit OS)
5. copy it to \EFI\Boot\ folder of the USB flash drive
6. launch the BIOS SETUP to disable "Secure Boot", save the changes and exit the BIOS SETUP
7. boot from the USB flash drive
8. show EFI variables
   dmpstore -b *Revoke* [Enter]
9. you'll see "Revoke" information
10. delete the "Revoke" information (in my case, I needed to delete two EFI variables below)
    dmpstore -d RevokeSiSPolicySigners [Enter]
    dmpstore -d RevokeSiPolicyVersion  [Enter]
11. shut down the computer from the EFI Shell
    reset -s [Enter]
12. (optional) launch the BIOS SETUP to enable "Secure Boot", save the changes and exit the BIOS SETUP

I hope this helps.

101 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.