Build 14905 Fails to Rollback Properly

On my test computer I have setup two partitions. One partition is running build 14393 public build. My second partition is running Windows Insider Builds. i was not getting build 14905 even though set up as fast and was set at build 14901. Dual boot working fine. My primary partition received build 14905 (forgot to take it off fast). I let it update to build 14905 with the intention of rolling it back to build 14393 once my second partition received build 14905 which it finally did. I wound up with two partitions with build 14905. I then booted my primary partition to restore to prior build 14393. Windows prompted me to do the steps to restore previous build. When it restarted nothing happened it stayed at build 14905. Finally I tried a 2nd time then it finally worked. With build 14901 a similar thing happened except that time it would not restore at all finally reinstalled build 14393. At least some progress on rolling back but still not working as expected. Dual boot is working properly now.

I did send feedback on this issue.

 

Discussion Info


Last updated May 18, 2018 Views 70 Applies to:

Do you actually have the option to Rollback in Recovery?

Mine are greyed out, but I figure that's part of the Settings issue.

***********
*********

Please mark my posts as answers or helpful if they are.
Yes both in first failed attempt and again yes on one that worked. It asks several questions why you want to roll back and one of the options you can type complete reason.