Build 18252: Inbox App Fix

Hello Insiders. There is a known issue for build 18252 that will cause Inbox Apps to not be able to launch after the update for some users. One of the following two fixes should resolve the issue if you run into it.

What: Some Inbox Apps will not launch 

When: After updating to build 18252

How to fix:

There are two options on how to fix this.

  1. Register a specific application that is not launching. They can use partial names as well to accomplish this.
    1. Get-ItemPropertyValue -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications\*<PackageName>*\' -Name "Path" | Add-AppxPackage -DisableDevelopmentMode -Register
    2. EX: Get-ItemPropertyValue -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications\*WindowsStore*\' -Name "Path" | Add-AppxPackage -DisableDevelopmentMode -Register
    3. EX: Get-ItemPropertyValue -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications\*communications*\' -Name "Path" | Add-AppxPackage -DisableDevelopmentMode -Register
    4. EX: Get-ItemPropertyValue -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications\*mixed*\' -Name "Path" | Add-AppxPackage -DisableDevelopmentMode -Register

  1. Register all preinstalled applications. This is more aggressive as it will shutdown any packages currently running, takes several minutes to run as opposed to a few seconds but simpler to use and would fix all preinstalled packages having this specific issue.
    1. Get-ItemPropertyValue -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Applications\*\' -Name "Path" | Add-AppxPackage -DisableDevelopmentMode -Register -ForceTargetApplicationShutdown

As always, if you have problems getting this to work let me know here in this thread as well as on the Feedback Hub. Thank you.

this is not he only problem. network is not working properly on a surface pro 4

Registering all preinstalled applications do fail

Add-AppxPackage : Cannot find path 'C:\%SYSTEMDRIVE%\Program Files\WindowsApps\Microsoft.DesktopAppInstaller_2018.814.1
946.0_neutral_~_8wekyb3d8bbwe\AppxMetadata\AppxBundleManifest.xml' because it does not exist.
At line:1 char:132
+ ... me "Path" | Add-AppxPackage -DisableDevelopmentMode -Register -ForceT ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (C:\%SYSTEMDRIVE...dleManifest.xml:String) [Add-AppxPackage], ItemNotFou
    + FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

That's because the paths list contain both C:\ and %SYSTEMDRIVE%. These don't work in PowerShell: you have to either use $env:SystemDrive or use the drive letter directly, which is always C:\ anyways because this list contain only apps preinstalled with system, and not user apps that may be stored on a different Get-AppxVolume.

If paths that contain CMD style variables are encountered while trying to register anything in that list, the path gets prepended by PSPath

thanks for the reply
hola quiero descargar manualmente la build 18252

hola quiero descargar manualmente la build 18252

Hola, no se puede descargar manualmente del sitio oficial.

Si quieres una ISO de esa version tienes que usar este tutorial o suscribirte en el WIP e instalarla.

FWIW this was again a problem for me with Insider build 18267, and #2 in the 1st group fixed it.

Is this going to be a recurring thing? Should I add one of these Powershell commands to the script I run after upgrading to each new build to unfubar the defaults each new build inflicts?

probably would not be a bad thing to do,I stopped running powershell ,I just use old fashioned cmnd prompt admin.seems as though the second download does the trick ,my download times are pretty fast and I have a fast machine or two ,so I just re-set the build when things go haywire .thanks for your kind suggestions mhg,takes me about 8 minutes .
Reply In reply to deleted message
Don't copy/paste already posted info, do you have a question?
I'm a unpaid independent Advisor/volunteer
These people are a pain. I've deleted his two posts in this thread.

Discussion Info

Last updated June 16, 2020 Views 2,498 Applies to: