"A media driver your computer needs is missing." error when installing Windows 10 TP onto some UEFI ThinkPad models from USB3.0 USB stick

I tried to install Windows 10 TP x64 Build 9926 onto my ThinkPad X230 which is set to UEFI only from a USB3.0 USB stick connected to the USB3.0 port. But an error message titled "Load driver" and saying "A media driver your computer needs is missing. This could be a DVD, USB or Hard disk driver." appeared and I could not proceed.

To narrow down the cause, I did the following:

  1. I checked the hash code of ISO, English (United States) version of Windows 10 TP x64 Build 9926, which I used for making the UEFI bootable USB3.0 USB stick. It was the same as the value specified in the download page. So ISO seems okay.
  2. I downloaded Japanese version ISO, checked the hash code and tried to install in the same way. I faced an error message in Japanese equivalent to English one. So language version does not matter.
  3. I burnt the ISO to DVD-R and tried to install from USB2.0 DVD drive. This time, the installation completed. So ISO itself is okay.
  4. ThinkPad X230 has two USB3.0 ports and one USB2.0 port. I inserted the USB3.0 stick to one of USB3.0 ports (so they communicate by USB3.0) until then. I changed to another USB3.0 port but no change. Then I changed to USB2.0 port (so they communicate by USB2.0) and finally the error message did not show up and succeeded the installation. So whether USB3.0 or USB2.0 seems to make the difference.
  5. I tested another two USB3.0 sticks of different brands and confirmed that when they were connected to a USB3.0 port, the same error happened and when connected to a USB2.0 port, no error. So it is not caused by hardware failure of a USB stick.
  6. I tested a USB2.0 stick and did the same thing with all three ports (so they communicate by USB2.0) and the installation completed without the error. So this issue seems not to happen when connected by USB2.0.
  7. I downloaded Windows 8.1 x64 enterprise evaluation ISO and did the same thing. The installation completed even when the USB3.0 stick is connected to a USB3.0 port. So this issue seems to be specific for Windows 10 TP.
  8. I heard some other people experienced the same problem with their ThinkPad X1 Carbon. So it is not limited to my ThinkPad X230.

In conclusion, I think there might be something wrong in USB3.0 support of Windows 10 TP installation ISO.

I was having the same problem you were with a Lenovo T430 (I believe it uses the same controller as the 230)  I have a USB 3.0 Sandisk Jump Drive that I put the image on.  I tried booting from the blue USB3 slots and it gave me the same driver error.  I rebooted with the USB Jump Drive in the Yellow charging / USB2.0 Port and it works fine.  

Hope this helps.

I tested the ISO of Insider Preview Build 10074 of both English and Japanese versions, and this error message did not appear and the installation completed. So this issue seems to have been solved.

I have the same problème.

I try with ca_fr and us_en in x64

I try with ca_fr and us_en in x64

Hi Arthtux, 

Have you tried ISO of Build 10074?

I cannot do anything to get past this error. I have a USB2.0 stick plugged into a 2.0 port and I have this error. I have changed setting in BIOS that have been recommended. What driver is required?  At least start there Microsoft and tell us what you are looking for. 

Bad error:  "Something is missing, we won't tell you what driver you just have to guess."  How are you supposed to troubleshoot a message like that?

This problem still exists, at least with the ISO file I downloaded this morning:

A media driver your computer needs is missing. This could be a DVD, USB, or hard disk driver. If you have a CD, DVD, or USB flash drive with the driver on it, please insert it now.

Note: If the installation media for Windows is in the DVD drive, or on a USB drive, you can safely remove it for this step.

This system has been running Windows 8.1 since it was released. The DVD drive is a standard LG model so I can't believe it's looking for that drive. I'm not using a USB drive so that's out and there's nothing special about the hard disk drive either. Why can't Microsoft at least give us a CLUE as to what it's looking for!!!

My solution: try to use a different USB port.

Edit: never mind, it restarted the installer and just hangs at the same media driver issue...


Discussion Info

Last updated December 2, 2020 Views 11,340 Applies to: