Question

Q: Can see other computers, but can't access their drives This thread is locked from future replies

In my Win10 PC, I can see other computers on my home network, but cannot access documents on them - says I don't have access.

This is not a big deal - I don't really NEED to access the other computers, but wondered if maybe a setting needs to be changed on my Win10 computer (Build 9841).  The 2 other computers on the network can see each other's documents (read and write), so I'm sure they are set up to share. 

The other 2 computers are running Win7, on a wireless network.  My Win10 computer is hardwired to the same router (the Win10 computer is an older one that doesn't have wireless built in).  The other 2 computers can see the Win10 computer, but cannot access its folders.

Suggestions?



* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

On your Win10 PC,

PC Settings > Network > Manage > (double-click on your connection) > (turn on "Find devices and content")

Did this solve your problem?

Sorry this didn't help.

207 people were helped by this reply


Thanks, just checked that (PC Settings > Network > Manage).

'Find devices and content' was already turned on.

Did this solve your problem?

Sorry this didn't help.


Hello there!

Did you try to connect via a Homegroup?

Regards!

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


Homegroup:  Not sure how to do that.

My other 2 (Win7) computers use the same simple password - which is different from the Win10 computer.

I tried entering the Win7 password in Homegroup on the Win10 computer, but that didn't work.

OK, found a password for Homegroup on the 2 Win7 computers - both those computers have the same Homegroup password - different than my log-on password.  (I didn't enter that password, wonder how it go there?).  Anyway, the Win10 computer liked that better, but gave me the following error:

"Something went wrong when setting up the Homegroup.  Run the Homegroup troubleshooter, or try again later"

I couldn't find a 'Homegroup Troubleshooter'.

Did this solve your problem?

Sorry this didn't help.


With my other computers, as long they have usernames and passwords I can access anything that the local account (on that machine) has access to. Without password protected accounts I have no access (just like a local account with a blank password when trying to RDP to the machine.

Did this solve your problem?

Sorry this didn't help.

10 people were helped by this reply


Sorry people, I had to go off-line for a while - to do some work-for-pay.

Anyway, back to this question.

I can get into an external drive attached to one of the other computers on my home network.  But the other two PC's, running Win7 require a password, but I'm not sure how to get to a screen to enter a password from this Win10 computer.  The Win10 computer uses a different password than the other two PC's.

From this Win10 computer, how would I get to something to enter a password in order to access the drives on the other Win7 computers?

Did this solve your problem?

Sorry this didn't help.


Homegroup:  Not sure how to do that.

You should try set up a Homegroup on the Win7 and Win10 machines.

- look at networking  in Win7, and in Win10 type Homegroup into search.

Then you could look at mapping a drive (from within Win10's File explorer) to your external drive.

Did this solve your problem?

Sorry this didn't help.


OK, seems the actual difference between 9926 and prior builds/OS, is that the Group Policy for "Network access: Sharing and security model for local accounts" now defaults to "Classic" (previously the default on domains).  I believe previously on workgroups/standalone it was "Not Defined" and therefore defaulted to "Guest" functionality.

Deleting any workaround registry hacks, then setting the following Group Policy to "Guest" appears to restore the prior functionality:

gpedit.msc > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > Network access: Sharing and security model for local accounts

Did this solve your problem?

Sorry this didn't help.

22 people were helped by this reply


OK, seems the actual difference between 9926 and prior builds/OS, is that the Group Policy for "Network access: Sharing and security model for local accounts" now defaults to "Classic" (previously the default on domains).  I believe previously on workgroups/standalone it was "Not Defined" and therefore defaulted to "Guest" functionality.

Deleting any workaround registry hacks, then setting the following Group Policy to "Guest" appears to restore the prior functionality:

gpedit.msc > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > Network access: Sharing and security model for local accounts

I don't think this is correct, I just checked on my Windows 8.1 computer and that group policy setting was set just like it is by default in Windows 10.

Did this solve your problem?

Sorry this didn't help.


In my Win10 PC, I can see other computers on my home network, but cannot access documents on them - says I don't have access.

This is not a big deal - I don't really NEED to access the other computers, but wondered if maybe a setting needs to be changed on my Win10 computer (Build 9841).  The 2 other computers on the network can see each other's documents (read and write), so I'm sure they are set up to share. 

The other 2 computers are running Win7, on a wireless network.  My Win10 computer is hardwired to the same router (the Win10 computer is an older one that doesn't have wireless built in).  The other 2 computers can see the Win10 computer, but cannot access its folders.

Suggestions?

MS pulled this rabbit out of its hat with the 9926 build with absolutely no communication about it.  There is a registry patch that will get you back to what has worked for over 15 years.  You can see it at this link:

https://social.technet.microsoft.com/Forums/en-US/4e9f7b19-d820-4d30-98c5-cd96e6d57cda/build-9926-the-account-is-not-authorized-to-log-in-from-this-station-error-with-network?forum=WinPreview2014Feedback

but here's the registry patch from that thread:

"A fix for this issue appears to be setting HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth (DWORD) to 1."

 It works for me, and it doesn't involve a whole lot of dinking around with homegroups or any of the above suggestions.  MS has said that they "missed the mark" with this surprise change in 9926, and promised to come up with something better in the future.  You can read that thread here:

http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/error-the-account-is-not-authorized-to-login-from/ffa63cc0-92d0-4639-9e3f-4d50100c1841

 Good luck.

Did this solve your problem?

Sorry this didn't help.

19 people were helped by this reply


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
Question Info

Views: 38357 Last updated: February 21, 2018 Applies to: