Windows 10 and IEEE 1394 FireWire Legacy Drivers (Unable to Install the 8.1 drivers)

I have a soundcard that requires the firewire legacy drivers. My Windows 10 upgrade went very well except I have not been able to get the legacy drivers to install.

In Windows 8, the driver stack for the 1394 legacy devices was separated from the regular installation (see

"FireWire port-based device does not work correctly in Windows 8.1 or Windows 8",  https://support.microsoft.com/en-us/kb/2970191). 

Running the Windows 8 driver installer In Windows 10, however, does not seem to work properly. A small window pops up then disappears. It says: "Please wait until Windows configures 1394 OHCI compliant host controller (legacy)." It disappears almost immediately. Too quick to read certainly. I tried to take a screenshot but failed.

No word if the drivers have been installed anywhere. I can't find the location and it is not coming up on search.

Anyone have success in getting the 1394 Firewire legacy drivers to install on Windows 10? 

Thanks for your help. 

Looking forward to getting sound back.

Vern

 

Question Info


Last updated November 21, 2019 Views 102,467 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I tried KB29701191 myself. Download and run the msi file. I can find the 1394bus.sys files etc at "\program files (x86)\1394 OHCI Compliant Host Controller (Legacy)" as expected. Can you double check it?

445 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried KB29701191 myself. Download and run the msi file. I can find the 1394bus.sys files etc at "\program files (x86)\1394 OHCI Compliant Host Controller (Legacy)" as expected. Can you double check it?

Same problem here with a Canopus ACEDVio card.

I right-clicked on the "Legacy1394.inf" file, chose "Install" and Windows changed the driver of that card. Now it works.

Thanks Wei Mao.

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

that was really helpful. 

the file is located  "\program files (x86)\1394 OHCI Compliant Host Controller (Legacy)"

legend! thanks Wei Mao

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Works as a charm both Maxtor drive and sony iLink DVD burner are up and running once again.

Now if anyone might have an idea what to stabalize my Lacie d2 quadra usb 5T drive.

It throws IO retries, disk resets and locks up the system. It's a brand new drive with that 

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have same problem with an old Fucusrite Saffire. Needs lgacy 1394 driver. Where do I download KB29701191?

John

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You can dowload it from here

https://support.microsoft.com/en-us/kb/2970191

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

John, I have the same issue with the original white Focusrite Saffire. It worked fine under Windows 7. I can't find KB29701191 either. I had already downloaded and installed a 1394 OHCI legacy driver but it was from a different source so I'm hoping the one from Microsoft is different and will get me up and running.

Don

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you everyone for your help. I was able to load the legacy drivers following the above instructions. So you guys are super helpful.

I think my audio interface is not making the leap to windows 10 however. The legacy drivers worked with it under windows 7 but the Focusrite Saffire is not completing the driver install even with the legacy 1394 drivers. The audio interface is no longer supported by the company.

So looks like I'm sticking with Windows 10 and getting a new audio interface. Onward and upward right?

Thanks again for the help.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem with Focusrite Saffire. Nobody having any luck making it work on Windows 10?

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I called Focusrite. They said it only supported up through 8.0  sigh. They are NOT going to write new drivers. They seemed amazed I was still using it.

John

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.