Win 10 Build 10049: Remote NDIS 5.1 Not working

Hello Forum,

When i connect a USB-Modem that supports Remote NDIS 5.1, i am only seeing the device enumerate in device manager under "Network Adapter" section.

The device never appears in the "Network adapter" section in "Control Panel->Network and Internet->Network Connections"

This issue happens only from Build 10049.

In Build 10041, the Network Adapter appeared fine in Network connections (was even able to able to perform network connection) when the USB modem was connected.

Has the support to Remote NDIS 5.1 (%RndisDevice% = RNDIS.NT.5.1) been removed from this build? Anyone facing the same issue?

Has changes been made to Microsoft "netrndis.inf" starting build 10049?

Thanks

Aby

 

Question Info


Last updated May 22, 2018 Views 532 Applies to:

Hi Abhay,

The issue you have posted would be better suited in the TechNet Forums. I would recommend posting your query in the link below.

https://social.technet.microsoft.com/Forums/en-US/home?category=WinPreview2014

Hope this information helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Sara.

Before raising a question in this forum, i had already posted the same question in social.technet:

https://social.technet.microsoft.com/Forums/en-US/7964a423-9eba-412d-a9df-d48f9897feb4/win-10-build-10049-remote-ndis-51-not-working?forum=WinPreview2015Phone

However, i am yet to get any response.

Hence i wanted to know, what was the difference between Build 10041 and 10049 that broke the NDIS 5.1 functionality.

From another thread, i see that starting build 10049, Microsoft is completely overhauling the "Network Stack". is it true?

Could that impact the new issues observed in RNDIS 5.1?

Thanks for your time.

Regards

Abhay

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sara

If you look at you list you posted it  in the Phone forum not PC.

Microsoft has re-written the network stack in 10049 to make it more reliable as you saw

On searching for NDIS 5.x I found this

NDIS 5. x has been deprecated and is superseded by NDIS 6. x. For new NDIS driver development, see Network Drivers Starting with Windows Vista. For information about porting NDIS 5. x drivers to NDIS 6. x, see Porting NDIS 5.x Drivers to NDIS 6.0.

Suspect you need to contact the modem maker for instructions or perhaps a newer driver.

Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Now that 10061 is available it may have changed.
-----------
If this answers your question - Then mark it so. Then others may find it.
---------------
Around computers
since 1952
lacrumb

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, i have checked in Build 10061. The functionality has been restored in this release.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.