Samsung Magician software doesn't recognize Windows 10, wont initialize RAPID mode

This functionality uses a portion of your RAM to increase read/write speeds on Samsung's new 850 EVO and Pro SSD drives. Everything is a go except that it can't seem to find that the operating system is Windows 10 and that it actually qualifies for RAPID mode.

I imagine it's because they didn't program it anticipation Windows 10, but I'd like for you guys to get to the bottom of it, because I like speedy file transfers and shorter boot times!

Thanks,

Ryan Maynard

 

Question Info


Last updated June 28, 2019 Views 97,517 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

fwiw;

Magician 4.4 installed and rapid enabled on every build I've tried up through build10166 on samsungs 850pro.  And I always overwrite it with magician 4.6 and rapid stays working.  Usually I uninstall Magician and Rapid and most all programs before attempting an upgrade build.

When I did the build 10240 I just did simple upgrade and left all the programs in place - Magician and Rapid stayed working.    Then I did an upgrade install again over itself to fix some windows items.

Have not tried a clean install yet.. waiting on the magic date July 29th to pass for that.

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Rapid started up again !!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

fwiw;

Magician 4.4 installed and rapid enabled on every build I've tried up through build10166 on samsungs 850pro.  And I always overwrite it with magician 4.6 and rapid stays working.  Usually I uninstall Magician and Rapid and most all programs before attempting an upgrade build.

When I did the build 10240 I just did simple upgrade and left all the programs in place - Magician and Rapid stayed working.    Then I did an upgrade install again over itself to fix some windows items.

Have not tried a clean install yet.. waiting on the magic date July 29th to pass for that.

I am using build 10240 and the 1TB Samsung 850 Pro I purchased today which isn't recognized by with Magician or by Data Migration. 

It's pretty frustrating to have a premium product unworkable with Win10.

Now I think the better part of wisdom may be to return this "puppy" until Samsung gets its act together.

Anyone have a recommendation?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Don't return it,  give it to me :)

It works fine without the magician software installed.

I've disabled Magician from startup here(startup task)

You can probably search and find Magician 4.4 if you want a 1gb rapid cache.

Rapid is a separate service.   

I suspect they will upgrade to a newer version of Magician quickly with the release of win10 but days away now.

Most people seem to complain about the Samsung data migration program fails... and use one of the many other clone programs with success. 

Pro is a good drive !  

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am using build 10240 and the 1TB Samsung 850 Pro I purchased today which isn't recognized by with Magician or by Data Migration. 

It's pretty frustrating to have a premium product unworkable with Win10.

Now I think the better part of wisdom may be to return this "puppy" until Samsung gets its act together.

Anyone have a recommendation?

I would recommend patience.

I'm running a Samsung 840 Pro on one PC and 840 EVO on another and 10240 on both.. Magician works fine, except for RAPID Mode. When I was running 8.1 and W7 I really couldn't see much real world improvement when RAPID was running and I had concerns how my RAM was being handled, so I almost always turned it off. It does look great on paper when you run the Performance Benchmark though. Your mileage may vary....

I don't have any experience with Data Migration, always preferred a clean install, pain in the butt to be sure, I just liked to start fresh.

I suspect Samsung will have an update for Windows 10 shortly, it would be in their best interest <smile>

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So here it is on July 30th and I have three computers all running activated RTM Windows 10 OS and none of them can use the Rapid mode on the magician software. 4.6 is a bust. Any day now Samsung, a new version any day. All you have to do is change the software to recognize Windows 10! I have have RAPID working on Win10 on my 840EVOs  by 4.4-4.6 trick but 4.4 does not recognize my 850Pro. My 850 Pro is just sitting on my computer desk waiting for you FIX THE MAGICIAN SOFTWARE!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think you should write this message to Samsung as they make the software, not Microsoft.

I have the same issue, but it is not something that Microsoft can solve, please write to Samsung as well.

Kind Regards

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have a solution for everyone!

1) Download and install the latest version of ProcessHacker2 - http://processhacker.sourceforge.net/

2) Open Samsung Magician and navigate to the Rapid Mode tab

3) Run ProcessHacker2 as Administrator then find and select the Samsung Magician.exe process in ProcessHacker2, right click and select Miscellaneous -> Windows

4) Search for the item listed with Samsung Magician as the text

5) Drill down and expand MDIClient

6) Find the first item SCort_ChildFrame that is not grayed out and expand it as well as it's SCort_SAT_View item

7) Right click on the Button with the text Enable and select Enabled

8) Click the Enable button in Samsung Magician!


78 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

2 Thumbs UP !

"C:\Program Files (x86)\Samsung\RAPID\RAPIDStatus.txt"  (Magician 4.6)
       *****************************************************************
       *                 Samsung Electronics Co., Ltd.                 *
       *                           2013-2014                           *
       *                                                               *
       *                           RAPID Mode                          *
       *                        version 1.0.1.91                       *
       *                                                               *
       *                      Installed 07/31/2015                     *
       *****************************************************************

         Status       = Enabled !!!
         Target Drive = Samsung SSD 850 PRO 128GB (119.2 GB)
                        Disk #0, C: G: (Boot)

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Nicely done! The hack definitely works! Before and after benchmarks below.

I'm going to spend some time with this enabled and see how it works. Previously I had a hard time seeing much real-world improvement in day in and day out use. I've got this on my insider test rig which I built a few years back so it's connected with a SATA 3Gb/s (SATA2) port and running 8GB of DDR2 Ram. I'll play around with some video files and see how well it works enabled and disabled.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.