Question

Q: Realtek HD ALC892 - DTS Connect not working

I cannot activate the DTS Connect output. If I choose it and try to play the test tone, I receive an error: "Error during playback" (German: "Fehler bei der Wiedergabe") or "This device doesn't support that sound format".

Settings:

DTS + DD + 48,8 khz activated and working with 2 channels, 16 Bit, 44.100hz.

"Virtual Sorrund" has no effect.

Using the standard driver that came with build 10041 / Windows Update, not the Realtek drivers.



* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting your query on Microsoft forums. 

Form the issue description, I understand that you are facing issues with the  Realtek HD ALC892 audio card. we are sorry for the inconvenience caused to you.

You might be facing this issue due to the incompatibility of the audio card with Windows 10 TP. I suggest you to download the driver from the following link and install it compatibility mode.

You can download the driver from the following link. 

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=1&GetDown=true&Downloads=true#ALC892

 

Now, to install in Compatibility Mode, follow these steps:
a. Locate the executable file (.exe file) for the driver installation program.
b. Right-click the file, and then click Properties.
c. In the Package Name Properties dialog box, click the Compatibility tab.
d. Click to select the Run this program in compatibility mode for check box, click Windows 8 with which it is compatible with in the Run this program in compatibility mode for list, and then click OK.
e. Double-click the executable file to start the installation program.

Hope this helps.

Please post back if you have any issues related to Windows and we will be glad to assist you further.  

Did this solve your problem?

Sorry this didn't help.


I more or less the same problem. I have a Supreme FX IV audio card from asus, it has the realtek ALC898 audio chip. My audio card only supports DTS connect, which I use to play surround sound on my sound system. Since build 10041 DTS connect doesn't work anymore, when I select it as default format and I play a test tone I get the following message: "Failed to play test tone."

On the previous build everything worked fine. The new realtek driver update 6.0.1.7458 didn't fix the issue.

Did this solve your problem?

Sorry this didn't help.


Hi,

I am sorry to hear that even you are facing this issue.

Have you tried to install these driver in compatibility mode?

If you haven't  tried that, I suggest you to go ahead and install the driver in compatibility mode and check if it helps.

Please post back with the status of the issue after trying these steps and we will be glad to assist you further.  

Did this solve your problem?

Sorry this didn't help.


So I tried to install the drivers in windows 8 compatibility mode, unfortunately It didn't solve the problem... Everything works except DTS interactive (the part that encodes 5.1 surround sound to DTS). DTS connect and DTS ultraPC II both work fine, and all outputs can playback sound. Except SPDIF can only use PCM and not DTS interactive...

Did this solve your problem?

Sorry this didn't help.


Hi, thanks. installing in compatibility mode hasn't solved the issue.

In my case, the ALC892 chip is onboard on my Asus M5A97 EVO R2.0.

DTS Connect (live converting all sounds to DTS and playback via SPDIF) has stopped working with build 10041, with the 9xxx it worked just fine.

Did this solve your problem?

Sorry this didn't help.


Hi,

I just patched to this version 10049 and this issue is now affecting me whereas I cannot Test DTS Interactive (5.1 surround) using my Realtek Digital Output (Optical) device on my machine.

This is an on board output and was working on the 9000 releases

Did this solve your problem?

Sorry this didn't help.


Hi,

I just patched to this version 10049 and this issue is now affecting me whereas I cannot Test DTS Interactive (5.1 surround) using my Realtek Digital Output (Optical) device on my machine.

This is an on board output and was working on the 9000 releases

The 5.1 issue is known and should be fixed in the next build we release. Once you have that build and can confirm the 5.1 works, I'd like to know what issues remain for you.

Thanks!

John W [MSFT]

Did this solve your problem?

Sorry this didn't help.


Hi,

I just patched to this version 10049 and this issue is now affecting me whereas I cannot Test DTS Interactive (5.1 surround) using my Realtek Digital Output (Optical) device on my machine.

This is an on board output and was working on the 9000 releases

The 5.1 issue is known and should be fixed in the next build we release. Once you have that build and can confirm the 5.1 works, I'd like to know what issues remain for you.

Thanks!

Build 10074, Realtek driver 2.76 (WHQL 0003-64bit_Win7_Win8_Win81_R276): DTS Interactive still doesn't work.

Did this solve your problem?

Sorry this didn't help.


Hi,

the same for me.

Asus Z97-A with a Realtek® ALC892 chip set. 

Another funny (annoying) thing is, that I have to switch of the dynamical clocking of my i7-4790K because otherwise I can not install new updates. Windows always complains that my CPU has less than 1GHZ.

Thanks,

Dainem

Did this solve your problem?

Sorry this didn't help.


Hi,

the same for me.

Asus Z97-A with a Realtek® ALC892 chip set. 

Another funny (annoying) thing is, that I have to switch of the dynamical clocking of my i7-4790K because otherwise I can not install new updates. Windows always complains that my CPU has less than 1GHZ.

Thanks,

Dainem

We noticed the dynamic clocking issue too, we're getting that fixed. Thanks!

John W [MSFT]

Did this solve your problem?

Sorry this didn't help.


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
Question Info

Views: 31,882 Last updated: May 22, 2018 Applies to: