GMA drivers or windows 10

How can I get Intel GMA 4500mHD drivers for windows 10?
 

Discussion Info


Last updated April 1, 2020 Views 63,976 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Kevin,

Any luck on a solution on your end?

i have some problem here can anyone help ?
intel send to micosoft and microsoft send to intel 
Not on Windows Update then? I'll have to look another day. I'd like to upgrade my laptop to 10 (currently has 8.1). I'd suggest asking on Intel's forum too.
Tried the just released windows 10, the GMA drivers for the previous windows, in my case windows 7 works just fine. Your just run the compatability mode and it will install the drivers.
That's about what I expected. Had to do that for 8.1

Hi, If still you are having problems installing the GMA drivers, even if you try compatibility mode. There is another way, I tried and it worked. 

Find " Win 7vista8_64_151719_v2" driver. ( I apologise I do not have direct download link, just Google it and note its for 64 bit OS)

After you download it follow the following steps.

1. Run Command Prompt as Administrator

2. Type [ bcdedit -set TESTSIGNING ON ]

3. Click enter

4. Restart your PC. ( Your PC will start in test mode. Which enable installation of digitally unsigned drivers)

5. Install the drivers,( just ignore the windows warning about the driver being unsigned)

6. If installation is successful, then Reboot.

NOTE: To remove test mode, just run CMD and type [ bcdedit -set TESTSIGNING OFF] then reboot. BUT THIS DRIVER WON'T WORK IF YOU DO THIS. So you are probably stuck in test mode ...... If you are okay with this then you can remove the watermarks which you see on the bottom right of your screen by using a watermark remover program. 

This driver is much better and stable than the ones which windows (WDDM 1.1) provides.

So far so good, I haven't exprienced any bug yet.

Hi, If still you are having problems installing the GMA drivers, even if you try compatibility mode. There is another way, I tried and it worked. 

Find " Win 7vista8_64_151719_v2" driver. ( I apologise I do not have direct download link, just Google it and note its for 64 bit OS)

After you download it follow the following steps.

1. Run Command Prompt as Administrator

2. Type [ bcdedit -set TESTSIGNING ON ]

3. Click enter

4. Restart your PC. ( Your PC will start in test mode. Which enable installation of digitally unsigned drivers)

5. Install the drivers,( just ignore the windows warning about the driver being unsigned)

6. If installation is successful, then Reboot.

NOTE: To remove test mode, just run CMD and type [ bcdedit -set TESTSIGNING OFF] then reboot. BUT THIS DRIVER WON'T WORK IF YOU DO THIS. So you are probably stuck in test mode ...... If you are okay with this then you can remove the watermarks which you see on the bottom right of your screen by using a watermark remover program. 

This driver is much better and stable than the ones which windows (WDDM 1.1) provides.

So far so good, I haven't exprienced any bug yet.

Hi,

can you play games in Full screen mode with these drivers? I am having problems with older drivers - when I try to play a game in full screen it has black borders.

Thanks

I can't tell you so much about gaming cos I haven't tried much. However, I have played games such as Asphalt 8 from store and it works just fine even in full screen. I have also tried COD 4 and its also okay even in full screen. So my guesss is Yes, depending on which game you are trying to play.

I am trying to play Need for Speed Most Wanted but whenever I start the game it does not display in full screen and it has black border on each side. When I open Intel Graphics control panel the scaling option has changed from Full screen to Maintain aspect ratio and I cant revert it back to Full screen.
Most wanted 2012 or 2005??? Either way I havent tested I wil give u a reply once i have an answer.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.