EMU 0404 USB 2.0 Audio Driver Problem In Preview Build 10041

I was using the latest drivers available for the EMU 0404 USB 2.0 audio device in the previous build (9926) without any problems. But when system updated to preview build 10041, the driver stopped working.

Applications trying to output audio now freezes and "The audio service is not running" message is displayed at the sound volume icon on the taskbar.

Uninstalling and reinstalling driver didn't solve the issue.


By the way, the driver version is 1.40 for Windows 7 x64 and it is a beta release because this device is no longer manufactured.

Now I wonder if it is a temporary state that will be resolved in the final release or this kind of old (but perfectly working) usb audio devices won't be supported any more.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I was using the latest drivers available for the EMU 0404 USB 2.0 audio device in the previous build (9926) without any problems. But when system updated to preview build 10041, the driver stopped working.

Applications trying to output audio now freezes and "The audio service is not running" message is displayed at the sound volume icon on the taskbar.

Uninstalling and reinstalling driver didn't solve the issue.


By the way, the driver version is 1.40 for Windows 7 x64 and it is a beta release because this device is no longer manufactured.

Now I wonder if it is a temporary state that will be resolved in the final release or this kind of old (but perfectly working) usb audio devices won't be supported any more.

Let me check whether we have on of these devices in our lab. If so we can try and figure out what's happening here. Thanks!

John W [MSFT]
Did you checked what went wrong with this interface in the last build? I use this device professionally and I'm afraid that I could not upgrade to Windows 10 if it happens to be uncompatible.

I have the same problem in build 10061.

Uninstalling and reinstalling driver didn't solve the issue.

This is a big problem for me, I use the card professionally.

Please keep it in mind.

Unfortunately we don't have one in our lab, and this device is no longer available for purchase.

I'll ask Creative if they can lend us one for testing.

John W [MSFT]

Here is an update about the issue.
I have tested older driver (version 1.30.07) on preview build 10061 and yes, EMU 0404 USB 2.0 audio interface is now working, but with some bugs. Headphone and Speaker outputs are not displayed in the playback devices menu (though with driver version 1.40, these options were available, but they didn't work). There is only digital output option and when it is selected as the output device, there is sound output at headphones and speakers, too. Mic input seems to be working okay. MIDI in/out are not tested but they are also available (Notice that using the same driver version in preview build 10049, MIDI in/out were not available).

And here are some findings:

1- When EMU 0404 USB 2.0 interface and PC are powered on at the same time, everything works as described. But, when interface is turned on while Windows 10 is running, audio interface freezes and does not respond.

2- To power on audio interface while Windows 10 is running, simply disconnect usb cable while audio interface is off and then power on the device and finally plug in the usb cable.

3- ASIO 2.0 drivers are also working. Software that supports ASIO 2.0 interface shows two outputs (analog/SPDIF) and two inputs (analog/SPDIF) along with midi input and output.

The tested driver version 1.30.07 is too old (from 2007 I guess) and probably Creative is not going to provide a new version for Windows 10, so it would be nice to see that Windows 10 has built in drivers for EMU 0404 USB 2.0 audio interface.

This is solid information, thanks! I will make sure that Creative is aware of this.

We can't produce a driver for this internally at Microsoft... We don't have enough information on how the device operates. Hopefully Creative will be able to do something for us.

John W [MSFT]
With the new Build 10074, the problem continues. Please keep it in mind.
With the new Build 10074, the problem continues. Please keep it in mind.

We were able to borrow a EMU 0404 from Creative. One of our software engineers is looking at it this week (as well as the X-Fi problems we've been seeing).

Thanks!

John W [MSFT]
With the new Build 10074, the problem continues. Please keep it in mind.

We were able to borrow a EMU 0404 from Creative. One of our software engineers is looking at it this week (as well as the X-Fi problems we've been seeing).

Thanks!

Thanks for that!

However, i was having different issue on windows 8.1 and i believe on windows 8 as well. Sometime EMU 0404 was hanging up and the only way to get it working again was:

- restart Windows Audio Endpoint (i wrote a batch script for myself)

- unplug USB cable from EMU or PC and power cycle EMU-0404

Could engineers have a look at this as well, please?

I couldn't find any event in Event Log for my issue, went through all of Events in Microsoft folder as well

With the new Build 10074, the problem continues. Please keep it in mind.

We were able to borrow a EMU 0404 from Creative. One of our software engineers is looking at it this week (as well as the X-Fi problems we've been seeing).

Thanks!

Thanks for that!

However, i was having different issue on windows 8.1 and i believe on windows 8 as well. Sometime EMU 0404 was hanging up and the only way to get it working again was:

- restart Windows Audio Endpoint (i wrote a batch script for myself)

- unplug USB cable from EMU or PC and power cycle EMU-0404

Could engineers have a look at this as well, please?

I couldn't find any event in Event Log for my issue, went through all of Events in Microsoft folder as well

UPDATE:

I've installed drivers 1.30 (which doesn't work in windows 7 AFAIR) but do work in Windows 10 and the issue is gone. I've been listening to music all day and playing guitar and nothing happened so i guess my issue was related to BETA drivers which are version 1.40

Sorry for making you confused

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Discussion Info


Last updated September 16, 2020 Views 18,629 Applies to: