Atheros wireless network adapter not working in Windows 10 Technical Preview

Hi,

When I tested Windows 8.1 Preview I had this same issue with the Atheros wireless connection. The same thing is happening with Windows 10 Technical Preview. So I am pasting the solution in case it helps:


http://answers.microsoft.com/en-us/windows/forum/hardware/no-wireless-networks-after-upgrade-to-windows-81/c9223bef-cd2e-4098-bdd2-34f8f8f70ac2?auth=1

I own a Lenovo G470 and my problem is solved.

Device manager was showing I had a Realtek wireless lan driver facing a startup error. I tried updating the driver even with a LAN connection working but had no luck.

Then I downloaded the latest Realtek/Atheros bundle drivers from the Lenovo support site, installed them and still no luck. The driver shown in Device Manager seemed to be the same that was installed before and still not working.

So I tried to update the driver choosing the Browse My Computer for Driver Software / Let me pick a list of device drivers. It showed three options: Realtek driver, Microsoft driver and Atheros driver. Tried each one, as soon as I chose the ATHEROS driver the wireless lan icon appeared and everything started working!

I hope this helps someone.

Now my Windows 8.1 notebook rocks.

Best regards and thanks for the help!

Cesar


 

Discussion Info


Last updated September 19, 2018 Views 75,881 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

My card is an AR5006XS and I have followed this instructions with no result. I've installed the Windows 8.1 drivers to see if I could be able to select them manually as indicated without result because I didn't get the Atheros entry, while it was already correctly detected on Windows 7. What can I be doing wrong? What could I do?

I believe you are hitting a known issue that we are working on addressing, until it is resolved can you try the following workaround?

  1. Open Device Manager, right-click the Realtek RTL8192DE Wireless LAN device and select Update driver software.
  2. Select Browse my computer for driver software.
  3. Select Let me pick from a list of device drivers on my computer.
  4. Select the “Qualcomm Atheros AR9285 Wireless Network Adapter” and install.

Hi Tripp. I have tried it but didn't get that option, only available verdors are "Intel", "Intel corporation" (yes, twice) and "Microsoft".

By the way, the card is identified as HP probably because my machine is one of them, but the card is a PCI generic one I added later. I've installed Windows 10 from the Insiders preview ISO by doing a clean install (removing the partitions and re-formating, too).

Hi,

When you open the device manger what do you see under Network Adapters? Is your card listed by name?  Is there anything listed under "Other devices" ?

Also when you went through the steps above did you uncheck the "Show Compatible Hardware" check box to get those three options to show up?

Jim

Hi Jim.

Yes, as I said in my previous post, the wireless card is identified as a HP one, but in fact is a generic one. There's a device listed on the "Other devices" section, but it's an old Logitec webcam that only had drivers for Windows XP (I have it attached because it's a really good can and works under Ubuntu).

Where is the "Show Compatible Hardware" option, on the menues? I don't remember to see it in the assistant... :-/

here is a screen shot of what I mean :)  if you could post a similar screen shot that would be great.  Also if you could get the hardware id from the details tab that would be great also.

I've follow your screenshoot and the checkbox was unmarked when it showed only the Intel and Microsoft entries. Now it showed a lot more companies including Atheros and Qualcomm, but probably this is related to the fact I tried to install the drivers for Windows 8.1. Anyway, the Atheros drivers were only for ethernet cards, and the Qualcomm ones always returned an error 10 "unable to initialize device", also the one for my exact chipset (AR5004G).

Where can I get the hardware id? I'll open later the computer case to look directly to the card to see if I can get more info.

back on the properties page click on the "Details" tab and select Hardware Ids" from the properties drop down.  Also, on the "Driver" tab it will show you the Driver Version, Date and Provider. 

Jim

Same problem with my i7 Lenovo Z560 - except I have just "cleanly" installed the 'market release' of Win10 Enterprise (64-bit)... and while I did not have to load an "OEM" driver under Win10 'Insider's Preview' version, this 'market release' reflected that it found a Realtek wifi - not the Atheros ..  Using your suggestion, Cesar, I 'browsed' - selected "Let me pick..." - opted for the Atheros and my useless "Realtek" wifi card became functional with the Atheros driver.  Nice catch...  and I'll make a note of this for my clients who will (no doubt) have similar 'mis-read' wifi and other hardware.

I've reinstalled Windows 7 OEM from the recovery partition and the Atheros card was correctly detected at the install process itself. I hope that installing Windows 10 via Windows Update will preserve the Atheros driver and also the one for my Intel graphic card (when I did previously a clean install it was not recognized too).

Anyway, this problem still needs to be fixed, so let's continue trying it :-) The driver is identified on Windows 7 as HP 802.11b/g Wireless Network Adapter, that's the same value that's identified on Windows 10, so seems that's not the problem. The hardware IDs are:

PCI\VEN_168C&DEV_001B&SUBSYS_500111AD&REV_01
PCI\VEN_168C&DEV_001B&SUBSYS_500111AD
PCI\VEN_168C&DEV_001B&CC_020000
PCI\VEN_168C&DEV_001B&CC_0200

The driver info is:

versión: 2.0.0.75

date: 09/06/2009

provider: Atheros Communications Inc.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.