ASUS Xonar Essence STX Users

Hey there

The Asus Xonar Essence STX Win 8.1 drivers do not work with Win 10. (on my rig the only drivers that don't work)

Try the UNi Xonar drivers http://maxedtech.com/asus-xonar-unified-drivers/ they work perfectly for me

As Asus belatedly released only Beta drivers for Win 8.1 (to shut everyone up I guess), I would not hold my breath waiting for official Win 10 drivers.

At least we have a workaround.

Cheers

 

Discussion Info


Last updated July 1, 2019 Views 20,600 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi FergusNerkle,

Thanks for the information, I'll let the audio team know.

Best,

John W [MSFT]

John W [MSFT]

Win 8.1 drivers work perfect for me in windows 10, you need edit some file in WIN81\ folder:

follow this steps:

1 - GO to asus support site

2 - Download the last driver for windows 8.1:

     - For example STX_8_1_8_1822_Win8_1.rar

3 - extract files and go to "WIN81" folder

4 - looking for "CmSetx.dll" file, and edit with notepad

5 - The configuration file, has 4 lines:

[SETUP]
ATYPE=30
INI_PATH=SoftwareDriver\InI
SupportOS=win81

You need modify like this:

[SETUP]
ATYPE=30
INI_PATH=SoftwareDriver\InI
SupportOS=donotcare

6 - save changes and run with administrator privileges "Setup.exe" of root driver package folder.

Greetings!

pd. Setup.exe from WIN81 folder not work.

Thanks, that worked. 

This does not work, although it seemed to work at first.

When changing the setting from windows control panel, it will no longer play (error : failed to play sound) 

Only works for analog stereo, not for DD5.1 live.

This does not work, although it seemed to work at first.

When changing the setting from windows control panel, it will no longer play (error : failed to play sound) 

Only works for analog stereo, not for DD5.1 live.

Thanks. We're still working on the digital 5.1 portion, it's not limited to just Xonar so the problem is almost certainly in Windows rather than in the drivers.

John W [MSFT]
Just to let y'all know this issue has been resolved in the final release. All works as it did in 8.1, etc.. :)

Just to let y'all know this issue has been resolved in the final release. All works as it did in 8.1, etc.. :)

Nice!

John W [MSFT]

Just upgraded to Windows 10 and it seems know that the AsusAudioCenter.exe will not load and without access to that I am unable to switch audio selections. It will not recognize my rear inputs off the card but the front headset jacks do which was the last setting I had during the upgrade.

I tried downloading the 8.1 driver from Asus but the error that pops up will say it is not supported.

Does anyone have a fix for this?

Thanks in advance

Just upgraded to Windows 10 and it seems know that the AsusAudioCenter.exe will not load and without access to that I am unable to switch audio selections. It will not recognize my rear inputs off the card but the front headset jacks do which was the last setting I had during the upgrade.

I tried downloading the 8.1 driver from Asus but the error that pops up will say it is not supported.

Does anyone have a fix for this?

Thanks in advance

Use XonarSwitch for that. 

The asus tools anyway's sxs bawls :) XonarSwitch gives you much more control over the soundcard and you can create profiles. 

I set it up that I press ctrl+alt+s for output on speakers and ctrl+alt+h for my headpones. It automatically loads my Equalizer presets etc.

Hi FergusNerkle,

Thanks for the information, I'll let the audio team know.

Best,

John W [MSFT]

I am fiddling since release of W10 with this audio card but somehow I cannot get it to install like I need it to. 

Windows 10 manual driver change does not see compatible drivers / inf files to do it manualy.

If I run the asus setup it installs but the driver version stays 10.10240.16384 and vendor Microsoft.

If I use the unixonar version a) It unloads the microsoft driver and then loads the Asus/cmedia driver (you hear the card clicking with the driver change) but after some time suddenly it clicks again a few times and the ms driver is reloaded. If you reboot also the ms driver reloads.

the b) version which I was using in windows 8, 8.1 doesn't even load it says install ok but after reboot nothing changed, just the ms driver is loaded again.

and Yes, I have my windows 10 in Test Mode as I run more unsigned drivers which need testing mode.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.