Microsoft Edge 10576 resetting to default PDF reader

Having done most things to get PDF's in general to open in Adobe Acrobat DC (which works for about a minute), Microsoft Edge then proceeds revert back to the default PDF reader, even when closed.

I use Acrobat all the time and don't want to "Open with" every time I need a document.
Is there a Registry entry I could delete or change to stop this happening?

I have also noticed that there is often a little refresh of the icons on my taskbar. This coincides with the reset of the default PDF reader to Edge.

 

Question Info


Last updated September 18, 2019 Views 22,556 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Dave, 

Thank you for posting your query in Microsoft Community.

I understand the frustration when things don't work the way it should. We will be glad to assist you.

Share this information to assist you better.

  1. Since when are you facing this issue?
  2. Have you mad any recent changes prior to this issue?

You can try and reset the default programs using the following instructions.

  1. Open Control Panel (All Items View) and click on the Default Programs icon. 
  2. Click on the Set your default programs link.
  3. In the left column, select (highlight) a listed program that you want to change it's default file associations for.
  4. To Set All of the Default Assciations to the Program -
  5. Click on Set this program as default.
  6. Click on the Save button to apply.
  7. Click on OK.

Next, then go and try to reset the association for PDF file to Adobe Reader.

Hope this helps. If the issue remains unresolved, please get back to us and we would be happy to help.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply Rakesh,

Unfortunately when I mentioned having done most things, this included your solution above. Also the direct assignment via "Associate a file type... ", right-clicking the PDF document selecting the "Always use..." option, and downloading the basic Adobe Acrobat Reader DC to see if it was my version.

Still the same result. The default is reverted back to Edge every time.

The only thing I have not done is investigate the Registry.

Would I be correct in assuming that there is a prosess, periodically checking on file associations in the background (would explain the icon flashes on the taskbar)? If this process is not receiving the updated association message then a revert to it's original association would seem logical.

This is a clean install of Windows 10 10576, and a clean install of the Adobe CC package. Installation date of yesterday and no other changes.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just for info...this problem is still present in 10586, so it seems there is an Edge registry key not being read or overwritten to give up it's defaults.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Still no luck in getting Microsoft Edge to give up the PDF default. I have had a look through the registry and am unable to edit any of the Edge entries for the .pdf default program.

HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.MicrosoftEdge_25.10586.0.0_neutral__8wekyb3d8bbwe\MicrosoftEdge\Capabilities\FileAssociations

-Error writing value
-Cannot edit .pdf. Error writing value's new contents

I have been able to edit the .pdf->UserChoice default program, but this just reverts back to Edge as with every other solution I have tried.

Any ideas anyone? Please.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same problem. No matter what method I try to make PDF files open with Acrobat, Edge takes control again. I notice also that I cannon uncheck the .pdf box for Edge when trying to change the defaults via the Control Panel.

I hope there is a way to roll back this update until it is fixed...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes you can.

  1. Right click a pdf document
  2. click Properties
  3. About 4 lines down where it says Opens with: Microsoft Edge, click the "change" button
  4. Under Other options click Adobe
  5. Click OK.

Let me know if this works for you!

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes you can.

  1. Right click a pdf document
  2. click Properties
  3. About 4 lines down where it says Opens with: Microsoft Edge, click the "change" button
  4. Under Other options click Adobe
  5. Click OK.

Let me know if this works for you!

No we can't. Edge just hijacks it back again. Nice try though.

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just discovered that Edge does the same thing with .htm files. It made itself the default. If I change it to Chrome (via ANY of the methods suggested here or elsewhere), then after a few seconds the icons pinned to my taskbar flicker once and Edge is once again the default for .htm (and .pdf).

Can other people change the Edge check boxes at ControlPanel/DefaultPrograms/SetYourDefaultPrograms/MicrosoftEdge/ChooseDefaults ?

There are checkboxes for .htm .html .pdf that I cannot uncheck, and these are the same extensions that Edge keeps highjacking.

I thought maybe MysticThumbs was the problem as the little icon on the PDF thumbnails also changes (from Adobe to nothing) when the Edge virus does its thing, but I've disabled MysticThumbs with no noticeable effect.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Through trial and error, I've made some progress. I uninstalled MysticThumbs and StartIsBack (and something called PunkBuster just because I didn't know what it was). The uninstalls required me to sign back in and restart, but now my changes to the default program settings seem to be enduring.

I set .pdf to Acrobat and .htm to Chrome by left clicking on a file and doing the usual "always use this app" thing. So far Edge has not hijacked them back, even though my taskbar has done the telltale flicker a few times (mainly when opening new windows).

If you have one of those three programs on your machine, perhaps it does not get along with the updated Edge?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have the same problem & I have MysticThumbs... Maybe if Windows would just add thumbnail support for adobe files we wouldn't have these stupid issues.  Does reinstalling MysticThumbs cause the issue again? 

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.