Build 15046 Edge won't reopen after being closed?? Anyone else having this problem??

When I close Edge it will not reopen and I have to wait for a couple of minutes to open it.

I have run troubleshooter and sfc and also reset IE 

Any suggestions or is this a bug?

 

Question Info


Last updated May 18, 2018 Views 113 Applies to:

Hi,

This possibly happens due to cache and cookies in Edge.

To resolve you concern, you can clear the cache and cookies in Edge, and see if it helps.

Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem and solved it with this article. Hope this helps you too!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When I close Edge it will not reopen and I have to wait for a couple of minutes to open it.

It seems to be due to the default Open...with setting.  E.g. instead of closing Edge when we close the Edge window it just hides it somehow from the Taskbar (No change in either Task Manager or Resource Monitor--not even Suspended?).   I suppose that would make sense as an implementation for the default--if it worked but it doesn't because trying to open it again doesn't work.  (Maybe I didn't wait long enough?  How long?  Does it depend on the number of previously open tabs or perhaps what those tabs were doing?  Who knows?)

Workaround:  either close all tabs separately before closing the Edge window or change the Open...with setting.   Then it will close and reopen as expected.

I suppose another thing to test would be to see if it ever goes away after it is closed under the default Open...with setting.  Then how long should we wait?   ; }

 

Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I suppose another thing to test would be to see if it ever goes away after it is closed under the default Open...with setting.  Then how long should we wait?   ; }

Looks like I'm not going to be able to find out.  Switching back to the default  Open...with  seems to have fixed the problem--for 2 tabs.   I.e., closing the window instantly changed all open Edge tasks to Terminating state (as should be expected).  YMMV.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.