Strange Fonts in Microsoft Edge

I recently upgraded from Windows 8.1 to Windows 10 build 10162.  The fonts in some pages in Edge are displaying a weird system font.

Any help would be appreciated.  Thanks!

 

Question Info


Last updated June 6, 2019 Views 4,742 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Kyle,

Thank you for posting your query on Microsoft Community.

I appreciate you for participating in Windows 10 and we are glad to assist you.

I would suggest you to check the language settings in Cortana and check if it helps.

Follow the below steps to check the language settings:

  1. Type Edit in Cortana.
  2. You will get an option Edit language and keyboard options click on it.
  3. Under Language option, check which language is set as default.
  4. If you find different language you can change it by clicking on Add a language option.
  5. Select your preferred language and set as default language and check if the issue persists or not.

I would like to inform you that Windows 10 Technical Preview is still in development stage, certain features might not work in the usual manner.

Full support for Windows 10 will be available when Microsoft releases Official Windows 10 on 29 July.

Reference: Refer to the following Microsoft article on Windows 10 FAQ.

http://answers.microsoft.com/en-us/insider/wiki/insider_wintp-insider_install/frequently-asked-questions-windows-10/5c0b9368-a9e8-4238-b1e4-45f4b7ed2fb9

Hope this information is helpful. Do let us know if you need any further assistance, we'll be glad to assist you.

Thank you. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is how my font changed. I tried your tips but it not helping.

Only display this font on MS Edge. My Chrome working normally

Please advise.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My fonts are similar to Tony's. I have tried everything I can think of to put them back to 'normal'. Like IE or Chrome's 'arial' type fonts. Does anyone know how to change the font face to something more readable?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Heyy, I solved it.

You need to go to C:/Windows/Font

Delete the font RixloveFox or I don't know, depend on what font are presenting in your computer.

Then reboot your device. MS Edge will automatically use other font, might be Arial as default. Problem solved. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

IT WORKS!!! Thank you SO much TonyTranktv91! I posted the instructions for finding out what font to delete. I'll give you big time credit! Thanks again!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've had this problem for years with Explorer, to the point that I've used Google Chrome for quite a while. Seeing your question told me I'm not the only one. I FOUND THE ANSWER!!  TonyTranktv91 posted it below, but there's a few steps to take if you don't know exactly what font it is that's messing things up.  So here ya go...

Based on Windows 10 and Microsoft Edge this is what I did:

  1. On the page that has the wrong font, select a small portion, right click, then selected Inspect Element.
  2. Based on what's selected I could see the font(s) that are used. Mine said Helvetica/arial/sans-serif.
  3. Close all programs
  4. Then go to C:\Windows\Fonts
  5. I started with Helvetica to delete
  6. I started up Edge and that took care of it! For the first time in years Comcast and Facebook are readable!

I hope this helps!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We think we've figured out what's going on. There are a lot of threads dealing with variations of the same issue, so instead of explaining here, here's a link to a thread with the details:

Wrong, "grafitti" font in apps and Web pages after upgrade to Windows 10

I hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Finally found the fix.....the above is way too much work and doesn't fix anything.

In windows 10, do a Cortana search for this exactly: c:\Windows\Fonts\Arial.ttf

Then Click : Run Command

Then click install, it will ask to reinstall click yes. 

Fixed. Worked like a champ!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bravo  ;)

It works for me, thank you so much "Chambers17"

Best answer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

For what it's worth, reinstalling c:\Windows\Fonts\Arial.ttf didn't work for me, Edge still displays some other serif font in place of Arial or "sans-serif".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.