Massive stuttering in games in Build 17063.rs_prerelease.17213-1610

As title suggests, I'm getting massive stuttering in all games in Build 17063.rs_prerelease.17213-1610. The problem always happens, with Game Mode OFF and Game Mode ON, makes no difference.

Any game I play, hangs every 2-3 seconds for like 100 milliseconds and then resumes, it is so damn frustrating.

I wasn't experiencing the issue in the previous Insider Build so it is clearly a problem in this build. No background process is interfering, Windows Defender is even disabled. No high CPU usage by other processes while I'm playing.

CPU: i5-7400

RAM: 8 GB DDR4 2400 MHz

GPU: GTX 1050 Ti

I found the reason of the problem, it's a Microsoft service interfering with the game while it's in fullscreen mode.

Looks like that the Microsoft service GraphicsPerfSvc uses around 30% of CPU while I'm playing, so the game doesn't run correctly at all.

Any attempts to restart the service fails (Error 1053), so I'm gonna disable this service and reboot the system, then I'll see what happens.

After disabling the service, I still get massive stuttering even though the CPU is only used by the game.

Please look into this.

Edit: Not having a clue on what to do, I tried to reboot the system 5 times in a row, just to try, and guess what? Stuttering is gone. I have no idea why it still stuttered after the first reboot, but it runs flawlessly right now.

I'm tired to reboot everytime I want to play a certain game. Can someone please look into this?
I am having the same issue. It's not the CPU that's the biggest problem. it's taking over 16GB ram

I found the reason of the problem, it's a Microsoft service interfering with the game while it's in fullscreen mode.

Looks like that the Microsoft service GraphicsPerfSvc uses around 30% of CPU while I'm playing, so the game doesn't run correctly at all.

Any attempts to restart the service fails (Error 1053), so I'm gonna disable this service and reboot the system, then I'll see what happens.

I'm having the same issue as well. So should I disable  Microsoft service GraphicsPerfSvc? How do I do that?

I have the same issue. Also whenever I exit full screen mode or there is some sort of windows notification, the game returns to run smoothly.

hope there will be a fix soon..

 
 

Discussion Info


Last updated June 12, 2020 Views 867 Applies to: