Windows 10 Pro Insider Build 17738 - No Soundblaster Audio

Soundblaster X-Fi Platinum can no longer output to speakers, only SPDIF is available as well as Speakers (HTC Vive) for my Vive headset

Only "solution" to date is to roll back to Build 17713.

Have tried uninstalling device from devices manager including the drivers completely and then re-installing the Creative driver pack, as well as Windows Update with no success.

The inbuilt Windows Troubleshooter can't do anything about it because it can only troubleshoot devices that are listed.

Since Speakers (Creative SB X-Fi) aren't listed after the update you can't troubleshoot them.

Have rolled back and tried twice with the same result.

I've seen at least one other post related to a Creative Soundblaster card losing audio after this update.

Is this only affecting Creative/Sounblaster devices or is it more widespread?

Hi Frizz,

Have you tried rolling back the Creative Soundblaster X-Fi Platinum driver after updating Windows 10 Insider build? Try uninstalling the driver, then restart your computer. Also, Windows 10 Insider build 17746 is out. Updating to the latest version might resolve this issue.

If you need further assistance, let me know by posting back. I will get back to you as soon as I can.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Its not helping.

Problem on windows side, and it still not fixed.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Build 17754.

Problem fixed.

After new build install, problem disappear like it was nothing.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I ended up upgrading to build 17755 which still didn't resolve the issue.

However, doing a "Keep my Files" Recovery fixed the issue while allowing me to be on 17755.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Fix my problem of the WIFI shutting down every 10 minutes

 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

FIX MY WIFI

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

good job

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 2, 2021 Views 254 Applies to: