Visual Studio Universal Apps. Windows 10. Developer Mode 0x80004005.

At the beginning of the development of universal apps in VisualStudio 2015 after upgrading from Windows 8.1 to Windows 10, I faced the problem that the constructor for "xaml" requires "Developer Mode". However, when activated in the settings for this mode, the Configure Manager return exception: 0x80004005. This case to work with a designer "xaml" there is no possibility.

And if done: Open the Settings app. -> “Apps & features” -> “Manage Optional features” -> “Add a feature” ->  package for Windows Developer Mode <Without this component for my OS configuration>
Don't fixed <https://forums.hololens.com/discussion/1530/fix-enabling-windows-10-developer-mode-get-error-code-0x80004005-after-build-14383>

To solve this problem (ENG):
1. Run Gpedit.msc
2. Go to "Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment"

To solve this problem (RU)
1. Run gpedit.msc
2. Go to "Конфигурация компьютера -> Административные шаблоны -> Компоненты Windows -> Развертывание пакета приложений Разрешить разработку приложений Магазина Windows и их установку из интегрированной среды разработки (IDE)" => Включить

3. Run PowerShell with administrator privileges.
4. To enable sideloading, run this command:

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModelUnlock" /t REG_DWORD /f /v "AllowAllTrustedApps" /d "1"

And

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModelUnlock" /t REG_DWORD /f /v "AllowDevelopmentWithoutDevLicense" /d "1"

5. Restart OS.

After starting the Visual Studio 2015 designer "XAML" in the project works without problems.

 

Discussion Info


Last updated September 5, 2019 Views 103 Applies to: